Support » Plugin: Email Users » No Line Return

  • Hi there,

    I’ve always had a problem with the email content never including line breaks. I know it sends a HTML file, but it doesn’t seem to be pulling through any line returns, is there a way of changing this?

    Thanks,

    Solomon

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    Any chance you have a plugin doing something with the_content filter? A lot of plugins do, I’ve seen a similar situation come up before. Because Email Users pulls post data, the the_content filter is applied to the post content before the email is sent.

    One thing you can try is to disable all plugins but Email Users and see if the line break removal persists. If it doesn’t, then another plugin is affecting the post content before Email Users sends it out.

    If it does, then you need to look downstream at email content before it is sent, Debug mode can help here but may not catch what you’re looking for.

    Not that I’m aware of, but I can’t say for sure. I’ll do some testing next week when I’m back and will let you know.

    Many thanks,

    Solomon

    I still have the same problem.

    I deactivated with health check all other plugins (also 2016 theme activated)
    Befor I tested some “suspicious” plugins to deactivate (PDFs processors)

    Still no line breaks

    With other plugins on, now putting the web address as the las line alone (not link) it is somehow autoembedding this:

    https://prnt.sc/jz2pno

    I guess Jetpack is doing this.

    But before with Plugin healthcheck was also bad working (no breaks).
    And health check disables all but mail users.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    If I understand what you are saying, the “box” in the image you posted with the “SONGBOOK”, rainbow heart, “Rainbow Songs” and small image on the right (not sure what it is) are added automatically if you have the web site url in the email?

    Yes this box appears automatically when I put only address (not link).
    Rights is a sign for sharing I guess. Left is a favicon (heart)

    I know similary from buddypress by posting in stream, but I don’t have buddypress here, so I think the Jetpack is doing this.

    For now also with all plugins on there is no box there but still continuosly text.
    With or without other plugins (healthcheck) same effect.

    Simultan I have difficulties with pdf plugins. I always have to reinstall them to have the worked. ;(

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Have you tried temporarily disabling JetPack to see if the problem goes away? I have JetPack installed on most of the sites I work with so it could be a particular feature of JetPack that is doing this.

    jaroslawistok

    (@jaroslawistok)

    I use almost nothing from Jetpack, but with a plugin health it will be in troubleshooting modus also disabled. that means only you plugin is on, other disabled and standard theme is on. Same effect.

    wpbccwnc5

    (@wpbccwnc5)

    I’m seeing the same issue with not getting line breaks.

    <br> <br /> does not work. It does not add a line break.

    <p> <p /> does not work. It does not create a new paragraph.

    <hr /> is in the default notification body. It works and adds a horizontal rule line.

    The strong commands are in the default notification body. It works and created bold text.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.