WordPress.org

Support

Support » How-To and Troubleshooting » no line breaks between links and link description

no line breaks between links and link description

  • even though i’ve formatted it in the backend by putting the line break tag in the Between Link and Description box, there is no line break between my links and their descriptions…any help?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Anonymous

    I am having this problem too.
    I would like to have a line break between my link and its descrition…
    I have tried the plugin above but it did not work. I kept getting ‘could not parse errors’.
    Why does the standard wordpress option of ‘before descrition’ not work?
    Any more help would be appreciated.

    Anonymous

    surely someone elso on this forum likes to have a linebreak between the link and its descrition….
    anyone…?

    Me! I tried the recommended plug-in but I couldn’t log-in to my admin section with it activated. I just got a bunch of error messages that said something about the “dtw_get_links_list”. So I had to uninstall the plug-in.

    Perhaps I’m misunderstanding the purpose of the “Between Link and Description” field in the Link Category section, but shouldn’t what gets put there appear between the links and their descriptions? Because NOTHING that I put there has any effect whatsoever on my blog…

    i figured out, through trial and error, how to get the “link description” to fall beneath the “link image/link name” in WP1.5 beta. I don’t know how it will work in WP1.2 but it’s worth a shot.

    I had to edit the “links.php” page in the wp-includes folder. Here is the block of code where i made the edit, (lines 211 – 219):

    if (($row->link_image != null) && $show_images) {
    if (strstr($row->link_image, ‘http’))
    echo “<img src=’$row->link_image’ $alt $title />”;
    else // If it’s a relative path
    echo “<img src='” . get_settings(‘siteurl’) . “$row->link_image’ $alt $title />”;
    } else {
    echo($name);
    }
    echo(‘‘);

    i added a
    tag to the last line (219) so it looked like this:

    echo(‘
    ‘);

    You can take a look at how it looks here: http://www.thisbluehippo.com/index.php?page_id=4

    **Note: this edit will add the line break on both your links page and in your sidebar. There may be other areas that it effects as well which i have yet to fine out.

    Any idea how to fix this with a plugin for 1.5? I don’t really want to go and make permanent changes to the links.php file as it might mess things up somewhere else.

    Seriously, what’s the deal? I seems as though the entire Formatting section of editing a Link Category does not work. I deleted the li tags as well with no effect. Kind of a bummer I must say. I’m gonna have to subscribe to the RSS feed for this thread… 🙁

    i wanted to bump this up, i’m having this problem in 1.5. i can’t figure out how to insert anything between the link name and the description…

    This is definitely a problem. Why have the option of changing these values if they have no effect?

    i tried to add that bit of code but it didn’t change anything also in the links.php file it’s not line 219 on my file

    i apologize, i entered the wrong line #. the line that you can change is line 526, not 219. sorry for any inconvinence.

    Anyone found a solution to this yet?

    I’m on WordPress 1.5.2 and the linebreak is working ok.

    I’ve just upgraded to 1.5.2 and I have the same problem with both the Classic and the Default templates.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘no line breaks between links and link description’ is closed to new replies.
Skip to toolbar