WordPress.org

Support

Support » Plugins and Hacks » [Resolved] No lightbox

[Resolved] No lightbox

  • I have an issue that the lightbox doesn’t kick in. I’m quite sure there are some dependencies missing because the lightbox feature works with no problems if NextGEN plugin is enabled. If I disable nextgen the chrome debugger says Uncaught TypeError: Cannot read property ‘msie’ of undefined from the fancybox pack js file referring to lines 18 and 46 of that file as anonymous function.

    There is also another error from the image-tiles.js file: Uncaught TypeError: undefined is not a function. This error refers to lines 13 and 2 of the file as anonymous function and to jquery min file. In jquery it refers to n.extend.each, n.fn.n.each, j, k.fireWith, n.extend.ready and finally to K.

    If you’d need any more info please let me know. Thanks in advance for your help!

    https://wordpress.org/plugins/maxgalleria/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author arcware

    @arcware

    Can you post the URL for where this is happening?

    Hi,

    Thanks for your reply!

    Here’s a url (it’s a test site for a client). Still happening as of today, but I’m adding more galleries, not sure if that’ll trigger any changes.

    http://mortimertest.co.uk/jvm/gallery-of-results/face/facelift/

    I don’t know why I didn’t check that earlier, anyway the lightbox effect works perfectly fine with the 2012 theme, but it breaks when I active Roots theme or my custom theme based on Roots. That’s a start 🙂 I’ll see what else I can find out.

    The only difference between 2012 and Roots in terms of what scripts are loaded is that 2012 loads jquery-migrate. When I added that to my Roots based theme, the lightbox effect started working as it should.

    Perhaps the plugin should list jquery-migrate as one of its dependencies, when enqueueing scripts?

    Plugin Author arcware

    @arcware

    Thanks for the info about jquery-migrate. We’ll look into it and see if it’s something we should add to MaxGalleria.

    Plugin Author arcware

    @arcware

    Looks like jquery-migrate gets included automatically, even up through WP 3.9.1. Can you verify if your Roots theme removes it?

    Apologies for my late reply.

    A quick search “Find in files” in Sublimetext didn’t show any references to jquery-migrate, so I can’t say for sure that Roots removes it. On the other hand a similar search through the twentytwelve theme folder didn’t bring up any results for jquery-migrate either.

    However if I enqueue the library in my theme the lightbox effect starts working. So I’m not really sure how jquery-migrate is otherwise included.

    Plugin Author arcware

    @arcware

    jquery-migrate doesn’t come from any theme, it comes from WordPress itself, which is why you couldn’t find it in the Twenty Twelve theme files. For the record, it’s in the /wp-includes/js/jquery folder.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] No lightbox’ is closed to new replies.