WordPress.org

Support

Support » Plugins and Hacks » Qtranslate Slug » No language selector – hardly wroted URL

No language selector – hardly wroted URL

  • Hello,

    I’m using the last version of WordPress and qTranslate Slug plugin too. I use on my website 3 languages. If I want to add into english version page URL to other english version page, it redirect me to page with translated slug, but without language selector and the result is a 404 page. (English is not the main language.)

    In “http://www.website.com/en/project/” page editor I want to add URL to page “http://www.website.com/en/something/”. But when I click at this link on the published page, it redirects me to “http://www.website.com/something/” without the /en/ selector. The link redirects good only if I use “http://www.website.com/?p=ID&?lang=en”. And when I write directly in the browser “http://www.website.com/en/something/”, it works fine too.

    I search some solution last 3 days and I tried all what I found (other permalink structure, all possible qTranslate options, my .htaccess is writable, etc.), but nothing works.

    Thank you so much for this great plugin and I hope, we’ll find some solution.

    http://wordpress.org/extend/plugins/qtranslate-slug/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Carlos

    @carlos_a_sanz

    Try with version 1.1.5

    Thank you for your respond, but it still doesn’t work with this version.

    Plugin Author Carlos

    @carlos_a_sanz

    Can you put some example ?

    Example of what exactly?

    When I click at common link added in administration through WordPress HTML editor – <a href="http://www.example.com/en/something/">Something</a> – it redirects me to “http://www.example.com/something” and show naturally 404 error.

    When I write “http://www.example.com/en/something/” direct to the browser window, it redirects me correctly.

    Plugin Author Carlos

    @carlos_a_sanz

    There is some example online for check out this issue ?

    Please go to http://www.jpminterier.cz/testweb/en/ and try to click for example at first slider image (it’s really a link to this page – you can find it in menu in Products / Faucets Vola). On this website is czech (Ĩesky) as main language and english as second language. The selector is on top left.

    If I click at link as slider image, also hardly wroted link in HTML wordpress editor, it goes to 404 page, the link is correct, but it redirects to a page without /en/ slug. And so is the problem with all hardly wroted links, it’s not because of that slider script.

    If I click at that page in menu, it works perfect.

    I use the newest version of qTranslate and qTranslate slug plugin.

    Many thanks for your respond!

    (That website is under construction, but it doesn’t have any influence for showing my problem, I have the same problem with other websites too.)

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘No language selector – hardly wroted URL’ is closed to new replies.
Skip to toolbar