WordPress.org

Forums

WP Fastest Cache
No input file specified when leave a comment (10 posts)

  1. IceThief
    Member
    Posted 11 months ago #

    Hello,

    i use this plugin but when a user try to leave a comment appears a black page with this error message: No input file specified.

    Any suggestions ?

    Thank you

    https://wordpress.org/plugins/wp-fastest-cache/

  2. IceThief
    Member
    Posted 11 months ago #

    error is in wp-comments-post.php

  3. Emre Vona
    Member
    Plugin Author

    Posted 11 months ago #

    Do you think that my plugin causes this issue?

  4. kaplunkiigirl
    Member
    Posted 10 months ago #

    Hi Emre,

    I'm having the same issue on one of my sites, and I do think that your plugin is connected to the problem, because I can temporarily fix the issue just by deleting the plugin cache.

    This is the site that's having the problem:
    http://www.eatingvibrantly.com/

    Unfortunately it's transient, I can't figure out how to reproduce it, but it keeps recurring after a period of time. At the moment, I just keep submitting test comments at regular intervals, and I'm slowly unchecking features one at a time to see if I can figure out what's causing it because I do NOT want to turn off your plugin.

    When I went searching on Google, most things I found said it was either a problem in the .htaccess file or a permissions issue on the wp-comments-post.php file.

    I completely deleted your plugin and the cache directory and reinstalled it, and the problem recurred.

    I'd love your thoughts on this one.

    Thanks,

    Nikki

  5. kaplunkiigirl
    Member
    Posted 10 months ago #

    OK, so I can't fix it without turning off the caching altogether - none of the other settings prevented it from happening.

    I also cleared out my .htaccess file entirely, leaving just the base WordPress permalink rules (plus the WP Fastest Cache rules), and the problem still occurred, so I don't think it's a clash with my other .htaccess rules.

    It appears that I have to wait 20 minutes before the problem presents itself - any time before that I am able to submit comments successfully - and I personally don't see the problem at all if I have the "Don't show the cached version for logged-in users" option checked, as if it's counting me as logged in (when I am not - I always use a different browser for testing, that I'm not logged into) because I've recently submitted a comment? Not sure about this one.

    I also took an exact clone of my site across to a development domain, and I can't get the problem to recur there (yet), so I'm thinking it might be something to do with the www redirect, but I could be barking up the wrong tree. But it's only happening on my live site unfortunately. What a frustratingly odd bug this is!

    I'm not sure what else to test, but I'm bummed that I've had to turn of the caching on my live site, which has taken my response time from 400-500ms up to 1200+ms :(

    Any thoughts as to where to from here?

    Thanks,

    Nikki

  6. Emre Vona
    Member
    Plugin Author

    Posted 10 months ago #

    Don't worry kaplunkiigirl, I will solve it in the weekend. I couldn't have time to work on it. sorry.

  7. kaplunkiigirl
    Member
    Posted 10 months ago #

    Thank you :)

  8. Emre Vona
    Member
    Plugin Author

    Posted 10 months ago #

    kaplunkiigirl, can you send me your theme please? I can solve the problem easily with this way.

    fastestcache@gmail.com

  9. kaplunkiigirl
    Member
    Posted 10 months ago #

    Hi Emre,

    I couldn't find a solution to this one. I thought it might have been my anti-comment-spam plugins, but even with all of them deactivated, the problem still occurred, just after a longer delay.

    I did some more digging, and I have a suspicion that it may have something to do with the way that my server handles the cached file request. I read somewhere that FastCGI, which my host uses, can be a bit fussy about file paths. But I can't be sure that's the problem, because I don't understand enough about how my server and your plugin are interacting.

    Unfortunately I've had no option but to stop using WP Fastest Cache, as much as I love it, because I can't afford to keep blocking my blog visitors from posting comments. I've switched to Quick Cache, and that seems to be working fine for me.

    Sorry we couldn't sort this one out. Let me know if you ever figure out how to fix it.

    Thanks for your help,

    Nikki

  10. Emre Vona
    Member
    Plugin Author

    Posted 10 months ago #

    Thank you kaplunkiigirl. You can use Quick Cache for a while. I will inform you when I find out how to solve the problem.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.