No input file specified (29 posts)

  1. razorwriter
    Posted 11 years ago #

    Anyone know what "No input file specified" means, when I load wp-login.php? It just started doing that, all of the sudden, although I can edit post just fine thru their individual links.
    Is it possible to "downgrade" WP from the latest nightly build to something more stable, by following the same steps as to upgrade?

  2. OperaManiac
    Posted 11 years ago #

    u can surely replace the files
    and hope that there has not been many database changes :(

  3. razorwriter
    Posted 11 years ago #

    hmm. I'm trying to re-install from scratch now (deleted and recreated my database - now it has no tables), but as soon as I get to install-config.php?step=2 (which it says is OK, can talk to the database) , and then install.php, it says "It doesn't look like you've installed WP yet" and reloads install.php with the message "No input file specified." AGAIN!
    I re-uploaded clean PHP files for everything, from the 1.0.2 dist.

  4. Anonymous
    Posted 11 years ago #

    I have this same problem. I have just installed wordpress, set a password, and when I attempt to login I get "No input file specified." How? Fix? Anyone?

  5. carthik
    Posted 11 years ago #

    I guess your servers are based on the Windows/IIS platform.
    You can use the latest build of 1.2 to solve the problem immediately, or wait till 1.2 is released, which supports windows servers in a much better fashion.

  6. Mustache
    Posted 11 years ago #

    I'm having this issue as well (on a new setup). I'm on a windows ISS server platform where the MySQL host is different from the localhost (I have specified the host name in the wp-config file).
    The Creation did not create the config file, so I edited it manually.
    Running the install results in the "It doesn't look like you've installed WP yet" and then the "No input file specifed" error.
    I'm going to search some more and see if I can't dig deeper into why this is taking place. I'm a ASP/MS-SQL programmer, so It'll take me a few weeks to 'wrap my head' around PHP/MySQL, so please be patient with me. :)

  7. Mustache
    Posted 11 years ago #

    UPDATE: I used the nightly build (wordpress-2004-05-10.zip) and I was able to get the database setup. I still get the error: No Input file specified when I launch wp-login.php.

  8. SuperSpiker
    Posted 11 years ago #

    I believe that this is due to running PHP via CGI as opposed to running PHP as an Apache Module.
    If you run PHP via CGI there are a few 'drawbacks':
    Variables in the URL won't work without using mod_rewrite (example.com/blah.php/username/info/variable).
    You can switch to PHP as Apache module, but there are some security implications.
    Good Luck!
    <Joe />

  9. hoekeat
    Posted 11 years ago #

    i am using IIS on Windows 2003, same problem here, cant even create any DB tables at all. Any solution?

  10. razorwriter
    Posted 11 years ago #

    Could this be because WP uses global variables? Our Windows host says this may be the case, but that's a big security risk on windows and thus they disable them.
    Still trying to figure out when I can get this working. With the latest Mingus release I'm not able to get into the system at all.

  11. Anonymous
    Posted 11 years ago #

    Just re-installed to delete my database, got the error you're describing.
    Solved it by removing unnessecary data in the .htaccess file. In this case, it was rewrite information used by my previous wordpress installation.

  12. Anonymous
    Posted 11 years ago #

    I, too am having the same problem - where is the .htacess file?

  13. Anonymous
    Posted 11 years ago #

    I had the same problem related to "virtual hosts" with apache. The solution for my problem was to remove the parameter doc_root in php.ini.
    I hope that helps.

  14. Anonymous
    Posted 11 years ago #

    I have the problem with my Apache server. I had never recieved that error before and then all of a sudden, it just screwed everything up. I couldn't find doc_root in my php.ini file either.

  15. Anonymous
    Posted 10 years ago #

    Same problem here but it got fixed by removing the doc_root in php.ini. I´ve had this problem before but couldn´t remember how I got rid of it.
    Anonymus (Aug 12, 2004 19:09:13): if you can´t find that line in your php.ini there is something wrong with it or you have removed it at some point. It´s there by default, quite far down. If it really isn´t there then there should be no problem for you since to fix the problem you just have to either comment it out or set it to nothing.
    This problem arises, of course, because if a doc_root is set in php.ini then php only interprets phpfiles that are located in or below this directory. So if you are using virtual directories (with whatever web server) that have a real path to somewhere else on your drive(s), the file will not be interpreted.
    Thanks a million Bernard!

  16. dfobare
    Posted 10 years ago #

    I'm trying to install WP on a Windows 2003 machine and also get the "input file not specified" message. I get it a little earlier -- when I try to run install.php. I have no php.ini file that I can find. That sounds like a Linux solution. Please, any help?

  17. Anonymous
    Posted 10 years ago #

    I had the "No input file specified" problem today. This was caused by wiping out the mod_rewrite rules in .htaccess. Adding them back fixed the problem right away.
    Make sure "RewriteEngine On" and the associated rules are listed in .htaccess. If not, go to your wordpress Admin screen, click Options, click Permalinks and scroll all the way to the bottom and paste what is in the textbox back into your .htaccess file.

  18. Anonymous
    Posted 10 years ago #

    I ran in that problem today, here is my setup: Windows Server 2003, PHP 4.3.9, MySQL 3.23.49 and IIS.
    I had coppermine (image gallery) running fine so i copied my wordpress folder under my coppermine folder and wp seemed to run fine. Then I realized my original wp directore didn't have php enable on it so I turned that on and it but still no sucess, I ended erasing it and copying the directory under coppermine. I did some tweaking in between so I'm not sure how that all worked out.
    One thing I noticed is that permissions on the wp directory are different now.
    Anyway, if I could have done it another way I would have gone the linux/apache way.
    maybe someone can find a real answer to that problem.

  19. Anonymous
    Posted 10 years ago #

    FYI - I am running W2K3, IIS6 and PHP5. I ran into the error, and commented out the "doc_root" parameter in my php.ini, stopped/restarted the web server, and things work great!

  20. Anonymous
    Posted 10 years ago #

    Its file permission errors guys. You have to allow ISUR_yourmachine to have access to the folder. Set the permissions right and this will take care of that error.

  21. 7milesdown
    Posted 10 years ago #

    What do you mean by a file error permission?>

  22. flanders
    Posted 10 years ago #

    Actually, it might be user error (at least in my case).

    After much trial and tribulation, I got install.php to run and it walked me through all of the steps. When I clicked the login link at the end I got the "no input file specified" error.

    So I tried changing my file permissions, but that had no effect. I deleted the tables from my database and ran install.php again, and this time when it asked I specified the proper installation point of WordPress.

    The first time it specified for me, but was wrong. I had trusted it and it used my website, http://wwww.xcursionists.com. However, my blogs are actually at a subdirectory, http://www.xcursionists.com/blogs. Once I specified that I was able to login successfully.

    I went back and reset the permissions that I had changed and then tried it again, and it still worked, so it wasn't the permissions. Could be that WP is looking in the wrong place for the files.

  23. peman
    Posted 9 years ago #

    I've tried almost everything above except changing the php.ini cause i have no access. I still have the same problem...

    When i try to login to wordpress i get a white page that says "No input file specified". I noticed that if i go back two times in my webreader to wordpress index page and refresh that page then i can see the site admin. So then i am logged in to the system and i have to do the same thing when i logout.

    However, i dont want to keep up like this, so is there a fix for this problem??

    Help appreciated


  24. svenjissom
    Posted 9 years ago #

    I had the "input file not specified" problem for all the internal links on my site until I created a .htaccess file in the wp directory with the content specified at the bottom of the admin/options/permalinks page. Voila! all is well.

  25. peman
    Posted 9 years ago #

    Hmm there is no content specified at the bottom of the admin/options/permalinks page. Its only the two fields where one can fill in the Structure and the Category base and below that theres nothing on my page?!?

  26. emprear
    Posted 9 years ago #

    First Sorry by me english.
    "input file not specified" is 100% asociated with PHP CGI installation.

    is related to 404 Not Found Status. You can fix the problem in Apache .htaccess file. use the next code
    ### fix para "no input file especified"
    RewriteEngine On
    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_URI} !-f
    RewriteRule ^.+\.php$ /error_/thisfiledontexists
    Of course you need "mod_rewrite" enabled, in the sample "thisfiledontexist", in fact, must be a inexistent file.
    Also you can customize the error page :
    ErrorDocument 404 /not_found.php

  27. kdallas
    Posted 9 years ago #

    I have a simple solution that worked for my configuration.

    First of all to emprear -- you are wrong... it does NOT always have to relate to the CGI installation.

    My configuration is... IIS6, ASP.NET, and PHP5 running as an ISAPI extension (.dll)

    I had a site running on standard port 80 in the usual wwwroot folder, and PHP worked fine. I created a second site using port 8088 and PHP pages always produced "input file not specified". This was occuring on computers on my LAN. After trying a lot of different suggestions and clearing the cache out etc... nothing really changed except I got the site running on localhost to produce a code 404 error instead of that unhelpful "file not..." message.

    If you're thinking that I failed to install the php extension for this new site, that would be a good avenue to take, but in this case I've installed PHP in the default site properties. Note that one usually needs to add the .php extension to the document cache as well...

    Alright.. so if you've all got it setup as it should be, (as I did.). You should be able to fix the problem with my suggestion below. Note that this is based on some comments above, but know that it is not necessary to run mods in realtime... and generally not best practise.

    Go into the php.ini file where your php installation resides (no this is not a Linux thing!).
    Find the line "doc_root = "
    Comment it out. (or delete the line).
    It is that simple. Most people point the root to wwwroot using an absolute path, which is fine for most configs. However it is redundant for ISAPI installs. It does sometimes need to be used for CGI installs, but this is one of the big CGI limitations, (apart from poor performance), and why everyone should switch to ISAPI.

    I hope this helps some people. I don't expect it will help everyone as some people have some unusual setups.

  28. mkrisher
    Posted 9 years ago #

    the No input file specified error can also happen due to file permissions. I had to reupload my WP files and change the file permissions during upload.

    -- Mike

  29. knowlengr
    Posted 8 years ago #

    This "no input file" thread seems to be well spidered, but has a confusing mix of problem and solution statements.

    In particular, one should distinguish between Win, Linux, Apache, and IIS, and CGI vs ISAPI scenarios -- which could have different causes.

    My variant was Win 2000, PHP5, IIS5, ISAPI. First I verified that PHP was working from the command line:

    php phpinfo.php

    If not, you have a PHP issue not related to the webserver you've selected. Fix that first. But I suspect if you are seeing "no input file", you've already got PHP mostly working.

    Then I had to change the PHP.INI setting for

    cgi_force_redirect = 0

    as noted here http://us2.php.net/install.windows.

    Unlike some of the postings here, I did not have a need to reboot the server, so long as IIS was restarted from the Services in Control Panel (the whole service, not just the site involved), nor did the doc_root setting, which was null, make any difference. You mileage could vary. Permissions problems could also be a cause.

    Beware of caching when testing solutions.

    Lastly, I am reminded how much time is saved by an all-in-one install as provided by http://devside.net if you have enough permissions to go that route. For Windows users, it's a big timesaver.

    Good luck getting around this nuisance.

    --Mark Underwood

Topic Closed

This topic has been closed to new replies.

About this Topic