Support » Plugin: WordPress SEO Plugin - Rank Math » “no index” for tanslated pages does not work

  • Resolved thaimacky

    (@thaimacky)


    It seems that I cannot set the robots meta to “no index” for translated pages (in WPML). It only works when I set it in the original language.

    I would like to “no index” only some of the translated pages but not the original language. is there any way to do that?

    • This topic was modified 3 months, 2 weeks ago by  thaimacky.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Rank Math

    (@rankmath)

    Hello @thaimacky

    Thank you for contacting the support.

    Please install the Translation Management plugin and navigate to WPML >> Settings >> Custom Fields Translation and set rank_math_robots to Copy once.

    That should fix the issue: https://i.mythemeshop.com/DSKPF2

    Here is a link to the support ticket:
    https://wpml.org/forums/topic/yoast-seo-meta-description-translation-not-working/#post-2802646

    Hope that helps. Thank you.

    …woohoo – this worked – thk u big ;))

    Plugin Author Rank Math

    (@rankmath)

    Hello @thaimacky

    Please update to the latest version. That should fix the issue.

    Appreciate your patience.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.