Support » Plugin: User Access Manager » No images work at all after switching file locking on

  • When you switch file locking on, the expected behavior would be that you have to re-place your images and other media files in posts/pages and so on manually, as the internal links change due to htaccess securing the uploads folder.

    Unfortunately, in 3.5 the images do not only disappear from posts and pages, but also from the admin interface: they are not selectable anymore, the “Media” pane shows “broken image” placeholders instead of the images and so on.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I would like to add that I successfully reproduced that behavior with another fresh install of wordpress 3.5. Additionally, I tested installing UAM on a wordpress 3.4.1 installation, then switched file locking on, then upgraded to wordpress 3.5 and it’s working. But this is of course not a solution for the site I am right now building, as this would mean to begin from zero again.

    I also found out that the settings for “file lock” looks different in the installation which has been upgraded: there is two options: “Locked File types” and “.htaccess password” which don’t appear on the not working version. See and

    In my “not working” installation where I have installed UAM on a freshly installed WP 3.5 I also found out that the links used for previews/thumbnails for images doesn’t contain the “?uamfiletype=attachment&uamgetfile” part which makes uam giving access to the files, the internal URLs used are still direct links and therefore no image previews, thumbnails etc are visible.

    It seems that these two things have something to do with each other, maybe some mechanism in WP has changed so that UAM cannot successfully install all its components…

    So, I really hope this get solved soon.

    OMG, it looks like I was completely wrong with my assumption made an hour ago. I have now tried some more things and I’ve found out that it seems to just not work when Permalinks are enabled. There is no problem with version 3.5 at all when permalinks is disabled.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No images work at all after switching file locking on’ is closed to new replies.