Support » Networking WordPress » No Images on Multisite (Grey Thumbs)

  • Resolved mdpdance

    (@mdpdance)


    I have images and media not working in my sub site (grey blocks in place of thumbnails): https://store.mdpdance.com They upload, to the server, show in the Media Manager, but are grey blocks/dots which go nowhere when viewed.

    I have other multisites on the same FTP that have images that work perfectly. The main site (https://www.mdpdance.com), images and media are uploading and appearing fine.

    Everything is up to date.
    Hosting: GoDaddy.
    Theme change does nothing.
    Current theme: Shop Isle with WooCommerce.

    Here’s the things I’ve done:

      – Set permissions to 755 (also tested 744) on my /blogs.dir and /uploads folders.
      – Defaulted the .htaccess file (current setup), also tested the recommended multisite .htaccess customization.
      – Turned off all plugins and themes, still the problem persists.
      – Upped the upload memory limit in my php5.ini file and in wp-config.php.
      Config in the php5.ini:
      memory_limit = 256M
      upload_max_filesize = 256M
      Config in the wp-config.php:
      define(‘WP_MEMORY_LIMIT’,’128M’);
      define(‘WP_MAX_MEMORY_LIMIT’,’512M’);
      – Checked my Network settings for my store.mdpdance.com where the following is setup:Upload Path: wp-content/blogs.dir/9/filesUpload Url Path: (blank)
      – Added the following line of code from here, no worky:
      RewriteRule ^.*/files/(.+) wp-includes/ms-files.php?file=$1 [L]
      – Haven’t touched the database except to clear the caches.

    I’ve been working on this for almost a year with no resolution. If anyone has any knowledge or things I can try, please let me know.

    Thanks in advance!

    • This topic was modified 2 months, 4 weeks ago by mdpdance.
    • This topic was modified 2 months, 4 weeks ago by mdpdance.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Did you reach out to the people at Shop Isle for help? That theme has a product slider or something that is probably the problem.

    It’s possible the theme doesn’t like being on a multisite also as multisite handles media slightly differently as to directory structure. It’s possible the theme needs some tweak to work with multisite and the author may not even know that.

    I would have probably swapped theme temporarily to get things working then swapped back to my preferred theme to finish tweaking things… if everything works fine in a default theme then you can figure you’ll need to talk with theme support for more help.

    Swapping the theme also points out the theme might be the problem as media works fine in multisite when handled properly.

    I don’t believe this is a WordPress core issue. It could be but I doubt it.

    I also don’t believe this is a core WordPress issue: this seems to be a theme issue, but if you’ve swapped themes and it didn’t fix it, then it’s probably some plugin causing this.

    The reason for my conclusion is that this is not just a case of broken image path or permission.. the site is actually trying to use some preset but non-existing placeholder image file woocommerce-placeholder.png (is this from Woocommerce itself?)

    Thank you for your input.

    The thing is, I check my FTP and the files I upload do upload to my /wp-content/blogs.dir/9/files/2019/08 folder. They just don’t show in WordPress (thumbs or images). They link to that 404 error page.
    I thought I figured it out by copying another URL Path from one of my working multisites, but that did not work. The working multisite link has this: /home/content/23/9314323/html/wpgahd1/wp-content/uploads
    I figured if I added the “/home/content/23/9314323/html” that it would work.

    This page mentioned the following:
    This is a change from Multisite 3.0-3.4.2, where images of subsites were stored in /wp-content/blogs.dir/ and were shown in http://example.com/files/ and http://example.com/sitename/files and so on. If you started with a Multisite install older than 3.5, it is not an error if your images show with the URL of /files/.

    I’ve been going down so many rabbit holes. It’s refreshing that maybe someone knows something about this.

    @jnashhawkins
    Yes, I have changed to many themes many times, and just tested Twenty Nineteen with no images. I used Shop Isle because it didn’t look horrible without images. On my page, you can see I have used my mdpdance.com WordPress to direct link some images.

    I wasn’t thinking about the blogs.dir path.

    Could you add this line to your htaccess file… Put this below the normal call for uploaded files.

    RewriteRule ^([_0-9a-zA-Z-]+/)?site9/files/(.+) wp-content/blogs.dir/9/files/$2 [L]

    None of my installs run the older MU style system as I’ve rebuilt both of my multisites several years ago. My first multisite was MU style with the old WPMUDev domain mapper and the blogs.dir.

    The numeric ‘9’ in site9 and 9 in the path after /blogs.dir/ is the ‘site number’ associated with each site according to the database (as seen in the network admin’s site editor also).

    Let us know what effect that has on things… you might need to tweak htaccess a little more also.

    • This reply was modified 2 months, 3 weeks ago by JNashHawkins.
    • This reply was modified 2 months, 3 weeks ago by JNashHawkins.

    I finally got the images to work!

    From your suggestion @jnashhawkins I went again into the .htaccess file and inputted this code for WordPress 3.0 through 3.4+:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
     
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
     
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    From this site: https://wordpress.org/support/article/multisite-network-administration/#htaccess-and-mod-rewrite

    The images load faster than I’ve ever seen them load before. I must have reconfigured the .htaccess file while updating things breaking this instantly.

    What I learned:
    – Make Backups of everything.
    – Don’t use cache/speedup saving plugins if you don’t know what you’re doing.
    – Ask for help always.

    I appreciate your time and thinking on this and hope someone in the future can benefit from this post as well. Thanks guys.

    @mdpdance Cool…

    Now that you have everything working well you might make a current backup sometime soon and then run a really good cache plugin like W3Total on there in anticipation of possibly needing a CDN sometime in the future.

    W3 and a few others works well with a CDN and a multisite can swamp a small hard drive pretty quickly which slows response a lot. Of course, a SSD helps but a CDN takes that whole load (just about) away from the origin server.

    CloudFlare may be another option also. CloudFlare is a proxy service more than a CDN though CloudFlare advertises as a CDN. A good cache plugin will benefit a proxy also as it enables the cache control headers.

    @jnashhawkins
    Very cool. This was the next thing on my list of things to do for our site since it has a slow CDN startup.

    I have looked into CloudFlare and really appreciate their 1.1.1.1 app for iPhones. I will look into these things you have mentioned. Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.