Support » Theme: Hueman » No images in Index scroller after update

Viewing 15 replies - 1 through 15 (of 15 total)
  • Theme Author Nicolas

    (@nikeo)

    Hi @tzook, can you share your website url ?
    Thanks

    Thread Starter Tzvook

    (@tzvook)

    Theme Author Nicolas

    (@nikeo)

    If you try to switch to not rtl, does it solve the problem ?

    Thread Starter Tzvook

    (@tzvook)

    Yep
    Changing top HTML declaration from:
    <html class="no-js" dir="rtl" lang="he-IL" prefix="og: http://ogp.me/ns#">
    to
    <html class="no-js" prefix="og: http://ogp.me/ns#">
    brings back the photos …
    it’s probably in the flexslider ??

    • This reply was modified 4 years, 3 months ago by Tzvook.
    Thread Starter Tzvook

    (@tzvook)

    🙂

    $('.flexslider').flexslider({
    <?php if ( is_rtl() ) { echo( '   rtl: true   ' );} ?>
                                       });
    
    Theme Author Nicolas

    (@nikeo)

    Oh thanks for this code.
    I actually did not realize that this option was available.
    Does it fix your problem ? ( I can see that your home page slider is still not working ).
    Let me know

    Thread Starter Tzvook

    (@tzvook)

    I didn’t try, since it would be better in the codebase … but flexslider has this rtl option and WP too …
    just a sec .. I’ll try ..

    • This reply was modified 4 years, 3 months ago by Tzvook.
    Thread Starter Tzvook

    (@tzvook)

    Nothing works for now ….

    Theme Author Nicolas

    (@nikeo)

    OK. I’m working on a fix on my side.
    Thanks for reporting the problem.

    Thread Starter Tzvook

    (@tzvook)

    I found out that it’s not the Theme issue, but a WOOcommerce issue.
    Both use flexslider, and when active – the WooCommerce call is being used
    unactivating woocommerce brings the images back ..

    Theme Author Nicolas

    (@nikeo)

    OK. I wonder why WooCommerce loads the flexslider on home when there’s no WooCommmerce product to show…
    Did this issue occur when updating to WooCommerce V3.0 ?

    Thread Starter Tzvook

    (@tzvook)

    I updated both WC and Hueman at the same time … so it’s hard to tell …
    but since it’s WC issue, it’s probably a “3.0” issue … yes ..

    Since I’m still waiting with “the Commerce” to go on-line … it’s only visible to Admin , but it’s scripts are embedded … 🙂

    Theme Author Nicolas

    (@nikeo)

    OK thanks for the information, this is useful.

    Hi @tzvook,
    we investigated on this and found that with the latest woocommerce, the plugin’s flexslider overrides the theme one.
    The woocommerce’s flexslider, if no rtl option is passed, and the html direction is rtl, forces that rtl option to true.

    That’s fine.

    The problem in your website, should be, due to the rtl.css you have in your child-theme which has this rule:

    .flex-viewport {
    direction: ltr;}

    to make the huemean’s flexslider working fine on rtl websites.
    That rule conflicts with the rtl flexslider’s option enabled.

    Could you please re-enable woocommerce and check if removing that rule from your child-theme/rtl.css the hueman’s slider works?
    Let us know 😉

    We’re about to update the hueman flexslider’s code to the latest version so that rtl users wouldn’t have display problems with the slider whether or not they have woocommerce enabled, but removing that custom css rule it’s required.

    Thread Starter Tzvook

    (@tzvook)

    Hi Rocco
    Spot-on … that did the trick.
    ( deleted the css .flex-viewport + activated the WC + made sure the call is the WC call … and it indeed works ).

    P.S. you may grab the rtl.css to make huemean “officially” rtl enable since it’s quite there anyway … putting it in the root of the theme will do the job automatically for RTL users

    • This reply was modified 4 years, 3 months ago by Tzvook.
Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘No images in Index scroller after update’ is closed to new replies.