Support » Fixing WordPress » No images

  • I have spent weeks with techs and software techs trying to figure out why images are not visible or can’t be loaded into the basic 3.5.1 wordpress. Obviously this keeps me from being able to create my new e-commerce site. Iv’e tried all available browsers and nothing changes including a complete uninstall and reinstall. Still no images?

Viewing 13 replies - 1 through 13 (of 13 total)
  • I suspect you should carefully scrutinize the credentials of the techs you’ve been hanging out with. URL to your site?

    They are the Godaddy techs and were only able to go so far with a solution , as they are not the authors of WP. Are you experienced enough to offer a solution rather than criticism? I could use it.

    Well, we could start with the fact that you have no user added content on the default twentytwelve theme. You actually installed this latest version of WordPress very recently (sometime yesterday ?)

    There is not one single request for a file possessing and image file extension in the server responses to your front page.

    The path to the logo that shows above your login dialog at /wp-admin is just fine… we’ll assume there is no problem with file ownership or permissions schemes – for now – that are preventing directory or image file access.

    The path to your uploads directory results in a 404.

    This indicates that you probably haven’t uploaded any images. If you had, I would probably get either a 403 error or a directory listing of the /uploads contents, depending on whether or not you prevent casual directory browsing.

    – Switch to a different theme that has a header image. See if it shows.

    – Create a post with some content and insert an image. See if is shows.

    – Or, navigate to Dashboard > Appearance > Header and upload a header and see if it shows in the twentytwelve theme.

    Right now, that theme is operating to design intent. I see no indication anywhere on your site or in your server responses that images are being prevented from showing. If you would like to try and add some image content, I would be happy to take another look later.

    Great BRB. I have tried to load images to the gallery and to a page and get only a blue question mark window for the image. in the Gallery I get only a grey screen and sometimes an error message. Only within WP.I will do it right now and will xplain what happens. Thanks

    I up load a new image into the Gallery via dash board. I open a new page and try to insert an image. Go to the gallery and all I see is empty grey boxes with no image.
    Another scenario is when I try to add images within the gallery, I drag and drop a jpg and I get only a grey empty box?
    Same if I try to upload it.

    I created a new post adde an image and I get a cracked image icon
    I uploaded a header image and nothing appears.

    The image you’ve uploaded to: is now returning a 403 error. Access forbidden.

    I suspect you have an issue with the permissions or ownership on at least the /uploads directory. That’s something solid you can to take to Godaddy support.

    Any further instruction I can tell them?

    I don’t think so. The main thing to let them know, is that when you uploaded your first image to the media library – which by the way is when the /uploads directory and /year/month directories first get created – you get a 403 error when trying to access or display the uploaded content.

    I thought at first it might be related to “hot-link” protection, but if that were true the images on your login page would be missing as well. I think there’s a permissions scheme error for some reason. I hope they can spot it quickly for you. What a pain that is..


    Any further instruction I can tell them?

    On second thought, yeah.. tell ’em to look at a server log once in a while.. HA!! Good luck to you! 🙂

    Thanks so much. This issue started about 3 weeks ago, and I have had to work backwards to find a solution. Thanks for your help!

    You’re welcome. I hope they can point you in the right direction.

    Craig Hesser


    Hello – I have been doing some work with “hardening” my WP sites, and I experienced the same problem as Andy Roy with one site that I am modifying significantly. I have not yet resolved it, but I am sure that the problem is in ownership of the images. When I look at the files available in the control panel, there are over 300 images, but when I try to use an existing image or upload a new image, they are forbidden 403. I also get the grey squares in the media library that Andy got.

    One of the “hardening” efforts I used is to protect images etc. from being modified or used (hotlinked) by others. This apparently persists even when the Better WP Security plugin (among others) is deactivated. I suspect the answer here is to deactivate the appropriate setting(s) in the original security software.

    I’m not going to link to my site because it is in constant flux, but then also sometimes off-and-on.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘No images’ is closed to new replies.