Support » Plugin: W3 Total Cache » No image when sharing link to WhatsApp only on Android

  • Resolved SottoVoce

    (@sottovoce)


    Hi,

    I noticed that since last W3TC update (0.9.7.3), any link shared to WhatsApp by using any Android device is now without an image. This same procedure works fine if the device is iOS.

    Thank you.

    • This topic was modified 2 years, 3 months ago by SottoVoce.
    • This topic was modified 2 years, 3 months ago by SottoVoce.
Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    Can you please share more details about your issue? Maybe share your URL or some screenshots for this?

    Thread Starter SottoVoce

    (@sottovoce)

    Sure Marko,

    This is happening when sharing any link to WhatsApp from an Android device. Normally, when you share a link to WhatsApp, it shows a «site preview» which includes meta description and featured image from post.

    I understand that property=og:image should be working fine, because if I share the same link by using an iOS device it works as it should be. Sharing to Facebook or Twitter is also working correctly.

    I guess that somehow WhatsApp user-agent is not able to pick the right image from post when generating that preview, and it is something related to page cache, because it works if I disable W3TC. The thing that I can’t understand is why this is only happening when using Android devices, and I tested using three different devices.

    For example this one is not working: https://www.aberturasldo.com.ar/puertas-multianclaje-ldo/ and same thing is happening to any blogpost.

    Marko, I hope that this help you understand what it’s going on.

    Thank you and regards.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    Have you enabled User Agent Groups in Performance>User Agent Groups?
    Are you sharing the link just by copy/pasting it or using the WhatsApp Share Button

    Thread Starter SottoVoce

    (@sottovoce)

    Hi,

    User Agent Groups are not enabled. The link is shared by using Android’s share menu from Chrome. I didn’t tested pasting the link directly.

    Thank you

    Thread Starter SottoVoce

    (@sottovoce)

    Hey guys, any update on this?

    tx

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    Please disable W3 Total Cache settings one by one and see which one is causing this. Also, make sure to save all settings and purge caches after each.

    Thread Starter SottoVoce

    (@sottovoce)

    Marko,
    Only page cache and browser cache was activated, but I tested disabling everything from «General Setting», and this is still happening. Only by having W3TC plugin enabled is causing that links are shared without images.

    I’m running out of ideas.
    Regards.

    Hi, @sottovoce

    If you are using something like Autoptimize, try do uncheck the in-line css option.
    I had the same problem and looks like the og: tags should no be far away from the top of the page.
    If it is not the case, try to move the og metatags up.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @sottovoce,

    If you are indeed using the Autoptimize, try disabling Autoptimize HTML minifier. Autoptimize uses the same library, but ours overwrites theirs. We’ve added an issue for that and it will be fixed in future releases.

    Thread Starter SottoVoce

    (@sottovoce)

    @rafawhs, @vmarko,

    Sorry for not answering earlier. Yes, I’m using Autoptimize, I will try your suggestions and let you know.

    Thank you

    • This reply was modified 1 year, 11 months ago by SottoVoce.

    Any updates? What is the configuration that generates that problem?

    @vmarko , any link to the open issue you’ve opened?
    This is indeed a big problem for me as well on: https://tachlescalcala.com

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @kazazor

    Here is the issue opened on our public GitHub repository. We do not have a timeframe at the moment on when the issue will be fixed but it’s in a roadmap.
    Thank you

    Thanks @vmarko !
    I have to say that disabling Autoptimize HTML Optimizer (you called it minifier in your comment, but it’s called Optimizer) did not solve it.
    Either doing something wrong, or your recommendation did not work.
    Was this tested as a possible workaround?

    @kazazor how you solve it?

    Regards.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘No image when sharing link to WhatsApp only on Android’ is closed to new replies.