Support » Fixing WordPress » No Image Upload in 2.1

  • Resolved arbitrarymarks

    (@arbitrarymarks)


    I have no image upload in my post window after upgrading to 2.1. The box where the upload was previously now points to my blog’s front page, but with a 404 page not found error.

    In the meantime, I can upload images directly to my server and point to them, but can someone explain where the box has gone in 2.1? (I’ve looked in the upload tab, and it only allows you to scroll through previously uploaded images).

Viewing 15 replies - 1 through 15 (of 19 total)
  • This is also a problem for me.

    It was working fine for me on two different installs I made last night… check to see if you uploaded all files to the wp-admin directory correctly?

    I have the exact same problem. I have checked that all the files are present and they definitely seem to be there. Is there an option that should be checked somewhere that I haven’t seen?

    Sounds like a similar problem to mine here. The upload box appears occasionally leading me to suspect a caching issue in the browser, however clearing and turning off caching did not resolve the problem.

    same to me…

    In response to Xander, I did triple-check the files in my install. I wound up rolling back to 2.0.7 and installing FCKeditor instead of using TinyMCE. When I rolledback, the image browser appeared, but I continued to get javascript errors. My Chenpress plugin has solved the problem.

    I’m in the meantime not rolling back. Anyone have a clue yet? I looked at the bugtrack and what I can see is that no one have noticed this problem yet!?

    I too am having the same issue…the upload dialog does not appear on the screen. I have tried with ie7, and Firefox. I have also tried disabling all plug-ins…..to no avail

    I have found a solution to this problem in the forum already. See this thread http://wordpress.com/forums/topic.php?id=6518

    Basically, disable or create a rule for adblocking software.

    Ashram

    Yeah. It is my adblocker from McAffee that makes this problem.

    Partial success. I tried turning off the adblocker and adding WordPress to the list of trusted sites.

    Good news: at least the “this feature requires iframe support” goes away, and I get a little frame like I used to before I upgraded to WP2.1

    Bad news: the frame just contains a picture of my home page with a 404 message 🙁

    Maybe you have to upload upload.php under the wp-admin folder again.

    I tried to add my blog as trusted site in McAfee without success.

    Any ideas?

    I’ve re-uploaded everything until I’m a bit bored… Nothing does much good. Thinking of moving back to WP v2.0.5 in desperation. Shame, because I’ve now ironed out all the other glitches in the upgrade.

    I had no problem adding my own blog as a trusted site (right click on the McAfee button at the bottom right of the scren, select Privacy Service>options then update the “allow list” tab. But it didn’t fix any problems for me…

    Cracked it.

    The Silaspartners Flickr plugin isn’t compatible with WP 2.1 yet. They’re working on it apparently.
    Disable the Flickr plugin and the old upload frame comes back. Re-enable the flickr plugin once you’ve uploaded the files.
    Pheww. This one was driving me seriously crazy.

    So far we have to use FTP for uploading ? i mean how to fix this matter ?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘No Image Upload in 2.1’ is closed to new replies.