WordPress.org

Forums

Social Media Feather - lightweight social media sharing and follow buttons
No image thumbnail on Facebook & Google+ (9 posts)

  1. neworld
    Member
    Posted 1 year ago #

    I'm appending SMF icons automatically into a default WordPress theme. When I click on the FB and G+ icons, there is no thumbnail displayed. the LinkedIn icon allows me to select images, but the default image is always a gray silhoutte, not the image in the post.

    How can I fix this? Thank you.

    https://wordpress.org/plugins/social-media-feather/

  2. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    Please provide a link to the page displaying the problem.

  3. jhd00023
    Member
    Posted 8 months ago #

    Hello! I have de same problem.
    Whe I try to share, the plugin take the correct URL, but has not image and in the title/description only use the domain name.
    It has the same problen in the blog page and in the single post page.

    the url: http://www.fxanimation.es/blogfx
    thanks a lot.
    J.

  4. dbaulch
    Member
    Posted 8 months ago #

    Same for me. I click the facebook share button. The post is prepared for me to go into gfacebook. I share it.

    When i got to facebook the post is there but it has placed my avatar image from wordpress in the facebook post rather than the image from the post itself.

  5. tecvoid
    Member
    Posted 8 months ago #

    google+ is working for me, its facebook that doesnt select the featured image.

    it is choosing a small image from a related gallery.

    i checked out all the share buttons including pinterest and its all great except facebook which is key.

  6. Synved
    Member
    Plugin Author

    Posted 8 months ago #

    I think this is a problem on Facebook's side - they are simply ignoring the parameter I'm specifying for image, instead picking up an image on their own that they choose. I think you can install an OpenGraph plugin to force FB to pick the right image.

  7. Synved
    Member
    Plugin Author

    Posted 8 months ago #

    It actually picks the right image for me for the link above, so looks like FB is maybe not updating it correctly for everyone.

  8. tecvoid
    Member
    Posted 8 months ago #

    the solution was to add this to my header:

    <meta property="og:image" content="<?php
    if ( has_post_thumbnail() ) {
    $full_image_url = wp_get_attachment_image_src( get_post_thumbnail_id(), 'full' );
    echo $full_image_url[0];}
    ?>
    " />

    maybe google will pick this up for others if i explain further.

    if you are using wpec aka wp e-commerce and you need the featured image to be specified for the facebook open graph guidelines, you need to use a little php to call the featured image in full size with no extra title alt or other attributes.

  9. jhd00023
    Member
    Posted 8 months ago #

    I fixed unchecking the "Display Follow Buttons" and using the PHP tag in the theme:
    <?php echo synved_social_share_markup(); ?>

    thanks a lot!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic