Support » Plugin: NGG Smart Image Search » No image search result

  • Resolved drowshan

    (@drowshan)


    Hi,

    Searching a test gallery is not returning any result. Here some information and troubleshooting I did:
    – WordPress 5.6
    – PHP version 5.6.40
    – NextGen version 3.5.0
    – No SSL (not enabled)
    – I am using the Widgets (Footer1)
    – Siteurl (as in wp_options): http://rowshanart.com/photos (searching for either fox or woodrat as a test should return a result). There are only two images in the galley
    – Enabled below in class-ngg-smart-image-search-public.php but not seeing anything in var_dump
    . define(‘hr_SIS_dump_mode’, ‘active’);
    . $hr_SIS_debug1 = 1 ;

    Please let me know if anything else needed for troubleshooting.

    Thanks!

    • This topic was modified 5 months, 3 weeks ago by drowshan.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author wpo-HR

    (@wpo-hr)

    Hi,
    there is something mixed up on your website.
    If you use the search widget (as you do in the footer) the search widget addresses the landing page ‘http://rowshanart.com/photos/search-ngg-images’ which will generate and display the search result (by using the display shortcode).

    However, your website returns a ‘page not found’. This page should automatically be generated upon activation of the plugin. Please check your defined pages in the wordpress backend to see whether the landing page is correctly defined.

    Also in the backend, you should check ‘settings -> ngg smart image search’.
    There the generated landing page is documented with page id, slug, title and an edit link. This page should exist and should contain the display shortcode.

    To test the functionality of the search plugin, just define any page or post and place the search shortcode and the display shortcode on this page:
    [hr_SIS_nextgen_searchbox]
    [hr_SIS_display_images]
    (see plugin homepage)

    There is no need for you to use the internal dump_mode.

    Thread Starter drowshan

    (@drowshan)

    Hi,

    Thanks for getting back to me. Here is what I did.
    I deleted wordpress and installed a new instance. Then, installed NextGen gallery and NGG Smart Image Search (verified the landing pageid=28, slug and title) and uploaded two images with description/tags for testing. After that I created a test page (http://rowshanart.com/photos/index.php/testpage/) and added below shortcodes and still not seeing any result:
    [hr_SIS_nextgen_searchbox]
    [hr_SIS_display_images]

    The plugin homepage link is returning 502 Bad Gateway error

    • This reply was modified 5 months, 3 weeks ago by drowshan.
    Thread Starter drowshan

    (@drowshan)

    Hi,

    Just wanted to let you know that I figured it out. WordPress installer had done a strange custom permalink. To fix the issue, I selected the “Post name” option.

    Thanks for making this useful plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.