WordPress.org

Forums

Recent Posts Slider
No image (9 posts)

  1. htc123
    Member
    Posted 1 year ago #

    Hi,

    I like this plugin until recently. I am using version 0.7.3. I have a weird case and could not figure out. I have a couple of posts and some of the images work but some don't. I also view the page source and found that there are no <img src > tags for the ones that having issues. I tried to remove the image from Media and set it again but still not working.
    I also checked/unchecked 'Organize my uploads into month- year-based folders' in Media Settings but no help.

    Any help would be greatly appreciated.

    Thanks in advance

    http://wordpress.org/plugins/recent-posts-slider/

  2. Neha
    Member
    Plugin Author

    Posted 1 year ago #

    Can you please share your website's url.

  3. htc123
    Member
    Posted 1 year ago #

    Hi Neha,

    Thanks for the swift reply. The current web site is on a VM of internal server that do not have external internet connection. Also I want to add that the slider works on go daddy site but now having issue on the VM. Also the image does not show on all the new images I updated to VM server. The weird part is that it works with some images already existed but not all of them. I also tried to insert image from 'Media' and 'Add to Post', both do not work.
    But I can see the image in the 'Featured image' of the post. No <img src > tag when view page source though.

    Any ideas would be greatly appreciated.

    Thanks

  4. Neha
    Member
    Plugin Author

    Posted 1 year ago #

    Can you please share the url(src) of images those are coming & those are not.

  5. htc123
    Member
    Posted 1 year ago #

    Hi Neha,

    Thanks for your reply.

    The good image path: <img src="/wp-content/uploads/2013/09/pdf_icon.jpg">
    Another good image path: <img src="/wp-content/uploads/2013/09/abcd.png">
    The bad image path that did not show would be: <img src="/wp-content/uploads/2013/12/abcd2013.png">

    Could you tell which table in MySQL would store the slider info please? This would kinda help to debug the issue.
    Should I try the new version of plugin?

    Thanks again for looking into this issue.

  6. htc123
    Member
    Posted 1 year ago #

    Hi Neha,

    I dig into the issue a bit more and found that there is no value in 'meta_value' for the problem post_id in 'meta_key' column '_rps_img_src' of wp_postmeta table.
    If I update the image path manually then the image shows up. So I am thinking there is an issue on writing the image path to MySQL database 'wp_postmeta' table.
    Any ideas would be appreciated.
    Thanks

  7. Neha
    Member
    Plugin Author

    Posted 1 year ago #

    Hi..
    Is 12 folder writable may be 09 is but not 12.

  8. htc123
    Member
    Posted 1 year ago #

    Hi Neha,
    Nope. Both 09 and 12 are writable. Actually some of images in 09 folder also not set correctly. I also see other posts having similar issue and wonder if it is the code issue instead of access issue.

    Thank you for looking into this issue.

  9. htc123
    Member
    Posted 1 year ago #

    Hi Neha,

    Just thinking out loud, is it possible that there is database timeout issue when writing? is it possible the problem is with the browser? I just realized that the browser on the VM is Firefox which giving me problem. But there is no issue with safari on mac when accessing to godaddy site.

    Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags