Support » Plugin: Glossary » No Gutenberg support?

  • Resolved kaisch

    (@kaisch)


    I wanted to add a new glossary term but it seems that your plugin doesnt support gutenberg. It opens up the old editor and it seems that there is no way to change it to gutenberg. How can I activate it?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi Kaisch,
    our plugin support Gutenberg, you need to check the settings of your website because we didn’t force users to use the classic editor.

    actually ive tried to use the plugin on a new site with literally no other plugin installed and it still opens new glossary terms without gutenberg.
    If i want to edit a site or a blog post gutenberg just opens up as normal.
    I dont have any idea where to look in the settings to change this.
    Do i miss something here?

    To see the classic editor instead of gutenberg you need that plugin installed, because wordpress doesn’t have anymore the code for that.

    We are not enforcing any kind of editor because our plugin support both editors.
    Can you share a list of the plugins do you have?

    I have run your plugin on several different wordpress installations,
    one was completely empty without any other plugin installed.
    It seems the classic editor is still somehow in wordpress, maybe its just a fallback?
    There seems to be a common problem with custom post types.
    If you create a custom post type without explicitly enabling gutenberg, the classic editor is what you get.
    Maybe enabling Gutenberg in your Glossary_PostType.php or the CPT_Core.php would help:
    ‘show_in_rest’ => true,
    ‘supports’ => array(‘editor’)

    Glossary already support editor as you can see at https://plugins.trac.wordpress.org/browser/glossary-by-codeat/trunk/includes/Glossary_PostType.php#L83
    The pro version has support for rest with that parameter because we add also other stuff on rest.

    I think that there is something with settings in that specific website that is forcing the classic editor instead of gutenberg.

    Ive found a solution. Its no website setting.
    The problem is in fact the missing ‘show_in_rest’ => true,
    Without this parameter, the Gutenberg editor just wont work. I can´t.

    Ive checked multiple sources:
    https://www.cloudways.com/blog/gutenberg-wordpress-custom-post-type/
    https://knowthecode.io/how-enable-gutenberg-editor-custom-post-type
    https://blog.kulturbanause.de/2020/01/wordpress-block-editor-gutenberg-fuer-custom-post-types-aktivieren/

    They all claim that Gutenberg wont work without this ‘show_in_rest’ => true, parameter.
    Ive tried it. Its true. You have to put this parameter into the code like here in the example, else it wont work:

    public function register_post_type()
    {
    $this->settings = gl_get_settings();
    // Create the args for the glossary post type
    $glossary_term_cpt = array(
    ‘taxonomies’ => array( ‘glossary-cat’ ),
    ‘map_meta_cap’ => false,
    ‘yarpp_support’ => true,
    ‘menu_icon’ => ‘dashicons-book-alt’,
    ‘capability_type’ => array( ‘glossary’, ‘glossaries’ ),

      ‘show_in_rest’ => true,

    ‘supports’ => array(
    ‘thumbnail’,
    ‘author’,
    ‘editor’,
    ‘title’,
    ‘genesis-seo’,
    ‘genesis-layouts’,
    ‘genesis-cpt-archive-settings’,
    ‘revisions’
    ),
    );

    After doing this, the plugin works like a charm.
    I really like your plugin and I want to use it, but trust me on this one.

    The next major version that we are working on already has this parameter enabled, so when we will release this problem will be fixed.

    I am wondering why in the other case and customers they don’t have any problem with gutenberg anyway.

    I too am having this issue. New install and its showing classic editor rather than gutenberg.

    Plugin Author Daniele Scasciafratte

    (@mte90)

    We are working to release soon as possible the new major with this bugfix.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.