Support » Plugin: Geo2 Maps Add-on for NextGEN Gallery » No geotags in uploaded images

  • Thanks for providing this plugin in a fresh version! It looks very promising and I would really like to have it working as it seems to quite exactly suit my purposes.

    However, any map comes up centered at my current browser location and no pictures are marked on it anywhere. The images have been uploaded via the NextGEN gallery uploader from my desktop and they do certainly contain GPS information in their EXIF data. They are taken with a recent smartphone and the imaging software Digikam shows the data. Though the NextGEN gallery overview does not show it in its metadata.

    Is there anything that I can do in order to circumvent the problem? Do others experience the same?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author pablo2

    (@pablo2)

    Hi, I checked and NextGEN doesn’t show GPS information in their metadata info. Maybe there is any other WP plugin that is doing this but I suppose you uploaded without any conversion the same photos which show GPS in digiKam so the problem must be somewhere else. Maybe there is a mistake in the shortcode you are using?
    Would you mind sharing it? Please also check other posts.

    btw. Geo2 Maps Plus – the extended version of the plugin on which I’m unfortunately still working is going to show EXIF info including GPS in the WP Media Library.

    Thread Starter sm8ps

    (@sm8ps)

    Many thanks for getting back, @pablo2 , and thanks for double-checking the meta-data shown by by NextGen gallery. That was confusing me. Indeed, the images are uploaded without any conversion and when I download them again, they do still contain the geolocation information lat/long plus respective references (north/south or east/west, respectively).

    I have read pretty much all of the posts here in the support forum to no avail. Originally I did not use any short-code; i.e. it was just the following int HTML:

    [ngg src="galleries" ids="1,2" display="basic_thumbnail" thumbnail_crop="0"]
    

    This does show a map below the gallery but it is centered at my current browser location and no images are marked anywhere on the whole map even if zoomed totally out and especially not in the expected location. Adding [geo2] in the front of the previous HTML I get another map that behaves exactly the same.

    The relevant meta-data as extracted by exiftool contains at least …

    GPS Latitude Ref                : North
    GPS Longitude Ref               : East
    GPS Longitude                   : 8 deg 51' 0.62" E
    Circle Of Confusion             : 0.005 mm
    GPS Position                    : 42 deg 29' 38.91" N, 8 deg 51' 0.62" E
    

    … and the “circle of confusion” is in fact pretty large on my end. (:

    Some images have more details in their meta-data:

    GPS Version ID                  : 2.2.0.0
    GPS Latitude Ref                : North
    GPS Longitude Ref               : East
    GPS Altitude Ref                : Above Sea Level
    GPS Date Stamp                  : 2021:10:16
    GPS Time Stamp                  : 06:43:57
    GPS Processing Method           : GPS
    GPS Altitude                    : 1133 m Above Sea Level
    GPS Date/Time                   : 2021:10:16 06:43:57Z
    GPS Latitude                    : 42 deg 28' 55.66" N
    GPS Longitude                   : 8 deg 52' 17.90" E
    GPS Position                    : 42 deg 28' 55.66" N, 8 deg 52' 17.90" E
    

    The difference is that some of the pictures were taken as panoramas where the camera software obviously strips away some information. — However the problem remains even when using only images with the complete geolocation information.

    • This reply was modified 9 months ago by sm8ps.
    • This reply was modified 9 months ago by sm8ps.
    • This reply was modified 9 months ago by sm8ps.
    • This reply was modified 9 months ago by sm8ps.
    Thread Starter sm8ps

    (@sm8ps)

    Some progress albeit not in the intended direction: when adding

    [geo2 worldmap=1]
    

    to the above HTML, I get a map with a red circular marker centered at LAT=51.24540 LONG=-1.23923 (as manually traced from a Opentopomap) instead of 42 deg 28′ 55.66″ N, 8 deg 52′ 17.90″ E (as extracted by exiftool).

    The only sense I can make of this is that the gallery is named “TEST4” and that the marker is placed on a small island in the midst of a lake labeled “Source of the river test”. This might be expected behavior but still I am confused.

    • This reply was modified 9 months ago by sm8ps.
    • This reply was modified 9 months ago by sm8ps.
    • This reply was modified 9 months ago by sm8ps.
    Plugin Author pablo2

    (@pablo2)

    Hi,
    Just try a simple shortcode like [geo2 id=1] Replace “1” with a NextGEN gallery number you want to show. Shortcodes [ngg…] will not work with my plugin. Only shortcodes specifically described on Geo2 plugin admin page are supported.

    GPS data is very likely correct. I suppose all companies are using the same standard to save it.

    Also, check FAQ on the main page of this plugin. Maybe you missed it. There are 9 topics that you can unfold.

    I suppose the Wordmap behaviour is correct. Wordmap is using geolocation if the preview image of a gallery doesn’t have GPS coordinates. Probably there is something called like TEST4. Change it to a name of a city or any real geographic location.

    Regards

    Thread Starter sm8ps

    (@sm8ps)

    Thanks for your support @pablo2 ! Unfortunately it does not seem to work at all. Here is what I did for trouble-shooting:

    1.) I copied the image
    http://www.geo2maps.com/wp-content/gallery/chile/DSCF3611.jpg
    from your website and verified that it does indeed contain gps values.
    2.) I uploaded that image to Nextgen gallery nr. 3 named TEST2 which contains no other images.
    3.) I embed the shortcode [geo2 id=3] into a test article:
    https://munterwegs.org/hightrails/2021/10/30/hello-world

    The result is a map centered at my current browser location without any images. I must be doing something completely wrong although I have read all the available info. Can you help me? Thanks in advance!

    • This reply was modified 9 months ago by sm8ps.
    Plugin Author pablo2

    (@pablo2)

    Hi, Could you try to disable other plugins to see if then it will work? Maybe there is a conflict. Of course except for the NextGEN.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘No geotags in uploaded images’ is closed to new replies.