Support » Plugin: WP Engine GeoTarget » No GEOIP Content Showing on Android

  • We want to show a different section of our landing page to different parts of Australia. It works fine on everything but Android. The offending code:

    [geoip-content country="AU,NZ" region=" ACT,NT,TAS,QLD,VIC"]
    some content
    [/geoip-content]

    [geoip-content country="AU" region="NSW,SA,WA"]
    some other content
    [/geoip-content]

    The issue is neither of these codes are showing any content at all on Android. Am I missing something simple here? Is there a way to show a default?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Taylor McCaslin

    (@taylor4484)

    Howdy Glenzy,

    Are you using a cellular connection on the android device? Many IP mappings for cellular connections do not properly identify location. This is a limitation of using IP addresses to determine location due to how cellular providers handle IP mapping.

    Default content is a good suggestion, I’ll add that to our feature request list. We’re working on 2.0 of the plugin presently, so we’ll definetly consider that feature. For now you can try to leverage the inverse operator to create essentially a default value:

    [geoip-content country="AU" not-region="ACT,NT,TAS,QLD,VIC"]Content for AU visitors but not ACT, NT, TAS, QLD, VIC regions[/geoip-content]

    You can read more about the various shortcode options here: https://wordpress.org/plugins/wpengine-geoip/other_notes/

    Hope this helps!

    Thread Starter Glenzy

    (@glenzy)

    Thanks for your quick reply!

    We just tried it on both 3g/4g and our Wifi and it gets the same result. It’s working fine everything but this 1 Android phone.

    *UPDATE*

    The particular phone thinks it’s in the US. Does this happen often? I’ve asked if he’s using a VPN or something and he says no, but Im not so sure. I just need to confirm it’s a 1 off with his phone or if it’s an Android-wide problem.

    Plugin Contributor Taylor McCaslin

    (@taylor4484)

    Hmmm. This sounds like a very particular issues with that specific Android phone’s connection. We haven’t seen any widespread issues with geolocation specific to Android outside of what I’ve already described.

    Thread Starter Glenzy

    (@glenzy)

    So upon further investigation, here in Australia, we have some random IP Addresses that don’t report as being in any of the states of Australia.

    My solution was using your suggestion above:


    [geoip-content country="AU,NZ," not-region="NSW"]
    [/geoip-content]

    and

    [geoip-content country="AU" region="NSW"]
    [/geoip-content]

    We want to include the entire world but exclude NSW. The above example has the same issue. It shows the content to all the states in Australia except NSW, but if I test it with “?geoip&country=US” no content at all is shown.

    Any ideas?

    Thread Starter Glenzy

    (@glenzy)

    *UPDATE*

    It’s passing all tests, so could have been cache.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No GEOIP Content Showing on Android’ is closed to new replies.