Support » Plugin: WP Security Safe » No General Settings Page

  • Resolved df03472

    (@df03472)


    I’m not seeing the general setting page. I only receive the following msg:

    Security Safe: All security policies are disabled. You can enable them in General Settings. (the “General Settings” link takes me back to this message.)

    I have deactivated all plugins thinking there may be a conflict.
    WordPress Version: 4.9.4

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author sovstack

    (@sovstack)

    @df03472,

    When you click on the link, it will take you to the Plugin Settings page, which used to be called “General Settings.” The notice will be displayed on all pages, including the page it links you to. You should see that the SS Plugin icon is highlighted orange in the main icon menu at the top of the page. If that is highlighted, then you are on the correct page. Scroll down until you see the main title “Plugin Settings.” Directly under that, you will see “Settings” and then “All security policies.” Change the setting for “All security policies” to “Enabled” and scroll to the bottom of the page and SAVE.

    When it saves, you will notice that there is a green notification at the top that says “Your settings have been saved.” You will also notice that you are still seeing the orange notification that says “Security Safe: All security policies are disabled….” This is a known bug. You are seeing that error because the plugin loaded the notification before your settings were saved. If your policies have been saved as Enabled, then go to another page by clicking on one of the icons in the icon menu at the top of the page and the notification will go away.

    Next release:
    – Rename that notification to say “Plugin Settings” instead of “General Settings”.
    – Make the link in the notification go directly to the setting on the Plugin Setting page.
    – Fix the notification load issue so that it does not display after saving the settings to “Enabled.”

    Let me know if the instruction above fixed your problem.

    Thanks,

    -Steven

    Plugin Author sovstack

    (@sovstack)

    @df03472,

    Thank you for reaching out for help. I have fixed the issues that you were describing. Please update to the newest version.

    -Steven

    Plugin Author sovstack

    (@sovstack)

    These issues were fixed in version 1.1.10.

    Updated to 1.1.11 still not working, turned on debug:

    Notice: Undefined index: general in /Volumes/ServerFiles/Library/Server/Web/Data/Sites/affright.com/wp1/wp-content/plugins/security-safe/admin/Admin.php on line 251

    Plugin Author sovstack

    (@sovstack)

    @df033472,
    It sounds like your settings in the database might be messed up. Try resetting them by going to this url while logged in: http://affright.com/wp1/wp-admin/admin.php?page=security-safe&reset=1

    Then let me know what happens.

    -Steven

    Plugin Author sovstack

    (@sovstack)

    @df033472,

    I have released version 1.1.12 and it will automatically detect if your settings are corrupted and fix them. Please update to the newest version.

    Also, if your problem gets solved, please reply with what solved it.

    Thank you,

    -Steven

    You were right the database had a problem. But the resetting URL did not work. Since I’ve been testing your plugin on a brand-new site I deleted the database, reinstall WP, and re-activated the plugin (SS 1.1.11). Success. Sorry now I didn’t save the old database, cause now I can’t fix the problem on my production site.

    I deleted the database again, reinstall WP, and re-activated (SS 1.1.10). Problem back. I now now have a database (with error) I can send you.

    Plugin Author sovstack

    (@sovstack)

    @df03472,

    The problem was fixed in version 1.1.11, but it did not entirely correct the settings issue in the database if your settings were corrupted. Version 1.1.12 detects the corrupted settings issue, deletes the settings and set the initial default settings.

    Thank you for helping make this plugin better.

    Thanks for using Security Safe,

    -Steven

    • This reply was modified 1 year, 6 months ago by sovstack.
    • This reply was modified 1 year, 6 months ago by sovstack.
    • This reply was modified 1 year, 6 months ago by sovstack.

    Since I recreated the problem. I removed the 1.1.10 from the plugin folder and installed 1.1.12, upon activating the new version, the plugin came up correctly. Problem resolved. Update fixed SS on my production site also. Thanks for all your help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘No General Settings Page’ is closed to new replies.