Support » Plugin: Breeze - WordPress Cache Plugin » No filter available to interact with the buffer before being saved into cache

  • Hi,
    This is a known issue but so far you never come with a fix/update. We continue to receive user’s complains about this, unfortunate we always had to instruct to switch for a different cache plugin.. So far, your code is the only one cache plugin which has not implemented a filter for the buffer cache.

    I’m the developer of WP Hide plugin https://wordpress.org/plugins/wp-hide-security-enhancer/ currently with +70000 active users.
    Our code helps to change default WordPress URLs like /wp-content/ and /wp-includes/ to something else. The problem is, when using your cache plugin, there is no filter available on your side which we can use in our code to change those URLs with customized ones.
    Specifically at /breeze/cache/execute-cache.php at function breeze_cache() we need a programable filter for the $buffer variable, before the put_contents() section e.g.
    $buffer = apply_filters( 'breeze_filter_buffer', $buffer )

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • I would love to see this happen as I had to leave Breeze because of this issue.

    I had to go to another caching plugin in the meantime until this is fixed.

    Plugin Author adeelkhan

    (@adeelkhan)

    Thank you for explaining the challenge you are facing. If you could provide a detailed use case, I could investigate the possibilities and get back to you.

    Thread Starter Maya

    (@tdgu)

    Hi,
    This is simple to replicate, just add WP Hide and customize a default URL (e.g. Rewrite > wp-content ) If Breeze is inactive, everything is fine, all URLs are updated to the customized URL, while activating your plugin, it creates cached files without the URL updated.
    That’s why I suggested a filter on your code which we can use to make the replacement before your code creates the static cached data.

    Thanks

    Thread Starter Maya

    (@tdgu)

    Is there any update for this?
    If you can’t update and include a way to filter the buffers, let me know so we inform our users as plugins not being compatible.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.