Support » Plugin: Yoast SEO » No File Editor

  • Resolved yuchit

    (@yuchit)


    Hi, as the title, I do not see “Tool > File Editor”.

    I clicked “Tool” and it only shows :
    “Import and Export”
    “Bulk editor”
    “Text link counter”

    However, I do not see “File Editor”. Is this normal?
    My version is Version 10.1.3.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • My Yoast is showing all 4: Import/Export, File editor, Bulk editor, Text link counter.

    I remember I saw it once when I just installed 2 days ago but now I do not see it. It’s strange. Look at the screenshot:

    https://snag.gy/KWsZMQ.jpg

    Plugin Support marcanor

    (@marcanor)

    Hi @yuchit,

    If your server permissions do not allow you to edit the robots.txt or .htaccess file, or if your WordPress installation has disabled file editing, you’ll not be able to use the editor.

    Please contact your webhosting provider for additional information on what your file permissions are.

    Hi @marcanor

    Thanks for reply, but I did see it when I just installed the plugin.
    However, after I read some article about it and I wanted to check it, it did not even show the option anymore, as you can see from the screenshot I provided above.
    I do have robots.txt and .htaccess and I also have edited .htaccess before via my server’s file manager (FTP) before.

    Plugin Support devnihil

    (@devnihil)

    We are referring to the file editing feature being disabled via wp-config.php so this wouldn’t affect file editing via the file manager of your control panel or FTP. When file editing is disabled this is due to the following directive being contained in your wp-config.php file:

    ​define( 'DISALLOW_FILE_EDIT', true );

    ​You can read more about enabling file editing here: https://codex.wordpress.org/Editing_wp-config.php

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to lack of activity.

    You’re always welcome to re-open this topic. Please read this post before opening a new request.

    Thanks for understanding!

    yuchit

    (@yuchit)

    Hi sorry, I did not see the email for the reply earlier until now.
    I did not find “define( ‘DISALLOW_FILE_EDIT’, true );” in my wp-config.php.
    It would have shown up from the 1st time when I just installed it if it had this I think.
    The wp-config.php I have now is pretty much the default one.

    • This reply was modified 4 months ago by  yuchit.
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.