Support » Plugin: WP RSS Aggregator » “No Feed Items found” withPolylang

  • Resolved dizou



    I restart the question which has been marked resolved without solution :/

    Since version 4.12.3 we have a message “No Feed items found” on the public pages while in the admin we have all our items.
    I have tested all new versions since but I have to stay on the 4.12.2 in production.

    We use Polylang and when I disable it the items will appear again in front. We can not do without Polylang, it is used throughout the site, so I could test only on a local development version.

    The problem persists whether we are logged in or not.

    We also use your plugin “Excerpts and Thumbnails” but that does not seem to be the source of the problem. I avoid turning it on / off because I lose all our archives each time (we have more than 400 items)

    Thank you for your help !

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Mark Zahra


    Hi @dizou, given that the issue disappears once you deactivate Polylang, we’ll be looking into a possible plugin conflict that might be causing this issue to happen.

    We’ll keep you updated.

    Hello Mark,

    Thank you for the feedback !

    Plugin Author Mark Zahra


    @dizou we cannot reproduce this issue when activating the free Polylang version on our test sites, with or without the Excerpts & Thumbnails add-on.

    Are you using Polylang Pro? Would it be possible to send us screenshots of the Polylang settings and your RSS Aggregator Template settings so we can try to reproduce your exact setup?

    Hello mark,

    I use the free version of Polylang.
    I tried with the default WP RSS Aggregator template but also with custom templates …

    I also tried with other WordPress themes (like Twenty Nineteen) and the result is the same: only when I deactivate Polylang the items appear (pages or posts)

    I also tried to call the shotcode directly via PHP in a very simple custom template, without success …

    As for Polylang, I checked “Feed Sources” in the settings (but I also tried without)
    Where do you want me to send a screenshot of my Polylang settings?

    Plugin Author Mark Zahra


    Hi @dizou, please send it to

    I also strongly recommend contacting Polylang about this to see if they can shed any light on the issue.


    email sent and message posted on the Polylang support forum

    Plugin Author Mark Zahra


    @dizou have you heard back from the Polylang team by any chance?

    Sorry for bumping the thread, it looks like I have the same conflict issue and I noticed that I also have an error “WP RSS Aggregator has encountered a critical error. […] Call to undefined function pll_get_post()” when I try to desactivate Polylang. That might be related 🙂

    Plugin Author Mark Zahra


    Hey folks, please check whether the issue persists with WP RSS Aggregator version 4.16. We have implemented a fix that fixes the incompatibility with Polylang.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.