WordPress.org

Support

Support » Plugins and Hacks » Simple Events Calendar » [Resolved] No February!!!

[Resolved] No February!!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Did you ever resolve this I have no February but 2 Marches? Any help would be great..

    Nope, just switched to a plugin that works properly

    Plugin Author Jerry G. Rietveld

    @jgrietveld

    Hi theresa95 and navitas,

    Apologies for not replying earlier. There was a weird bug in the code which would sporadically replace the month February with March. Without stepping into too much detail, this was caused by a functions that was partly taking the current date into account. For example, when you would be looking at the plugin on the 29th, 30th or 31st of a month, you wouldn’t see February because February only has 28 and sometimes 29 days. So even though it only displayed the name of the month, because it was also take the current day into account, it would read it as February 30th for example, which would result in March 2nd and thus March was shown in stead of February. I hope this makes any sense.

    Long story short, I will be fixing this bug in the Simple Events Calendar plugin tomorrow and I’ll let you know when you can download the fixed version. Hope you’re not too attached to the new found alternative theresa95 🙂

    Cheers,
    Jerry

    Hi Jerry – i fixed my issues mentioned 4 months ago and it has started again, i have most months twice. I had to reinstall the plugin after a few issues on the site. Is there an update available to yet. Just seen that you were back on this yesterday – what a coincidence. I was just searching for how I fixed it last time.

    Plugin Author Jerry G. Rietveld

    @jgrietveld

    Hi navitas,

    That’s really a coincidence 🙂

    Unfortunately there’s nothing you can do about this yourself right now. Please bare with me till I have the update ready in the coming days.

    Jerry

    You can fix this by changing all instances of
    date(‘F’, mktime(0,0,0, $i ))
    to
    date(‘F’, mktime(0,0,0, $i, 10 ))

    Essentially adding a day parameter that always exists…

    Plugin Author Jerry G. Rietveld

    @jgrietveld

    Hi mattbee,

    Thanks for your input! I’m in the finalizing stages of the new update so this will be fixed soon!

    Cheers
    Jerry

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] No February!!!’ is closed to new replies.
Skip to toolbar