Support » Networking WordPress » No Featured Image metabox in MU?

  • Resolved MatthewRuddy

    (@matthewruddy)


    Is it just me, or does WordPress MU not allow for post-thumbnails? There is no featured image box, and I cannot find any documentation on enabling it for MU. I’ve tried various themes. Nothing in the WordPress Post-Thumbnails codex pages mentions it not working in MU.

    Do they work?

Viewing 10 replies - 16 through 25 (of 25 total)
  • This gets me every time. Thanks Andrea

    add_theme_support( 'post-thumbnails', array( 'post', 'page' ) );
    This is the code i’ve been using in my functions file to add the Featured image meta box on single installation of wordpress.

    However this doesn’t work on a network setup. To get it to work i had to remove the array. Do you not need to target post types anymore?

    Check to see how they did it in TwentyTen.

    Yes I have, that’s why I know to remove the array. So it becomes add_theme_support( 'post-thumbnails');

    My question was do you no longer need to target post type?

    You never were required to target post types. The option exists if you wish to only enable support for certain post types (only posts, posts and pages, only pages, etc.).

    In MultiSite, you also need to go into /wp-admin/network/settings.php and check off the three boxes under “media upload buttons.” If those boxes are unchecked, post thumbnails won’t show up even if you’ve called add_theme_support( ‘post-thumbnail’ );

    Did you guys really solve this?

    It’s true that Featured Image metabox appears in main blog, but it doesn’t appears in network blog..

    When I navigate to another blog using both admin and super admin, it is not showing, even on Screen Options.

    Are the sub blogs using a theme that supports it? Cuz yes, it works for us.

    AAAAAah yes, it works!
    Thank you Andrea, it was my mistake to make it as an option in my themes to use post-thumbnail.

    Thanks again! 😉

    In MultiSite, you also need to go into /wp-admin/network/settings.php and check off the three boxes under “media upload buttons.” If those boxes are unchecked, post thumbnails won’t show up even if you’ve called add_theme_support( ‘post-thumbnail’ );

    It saved me ,

    network admin -> dashboard -> settings -> upload settings ->

    check the images, videos, …, thats all , featured image meta box will be shown in your post edit page.

    thanks TIM

    “On multisite, if you do not enable the IMAGE UPLOADS, under Network admin -> Settings, then …. well, that kind precludes having featured images.

    Tick that box. Save.”

    Thanks Andrea_r, your solution worked perfectly for me.

Viewing 10 replies - 16 through 25 (of 25 total)
  • The topic ‘No Featured Image metabox in MU?’ is closed to new replies.