Support » Theme: Superhero » No "Featured Content" in Customize or Reading

  • Resolved shanehou


    I downloaded the Superhero theme and used it on my private-hosted website, but couldn’t let the slider appear. In readme.txt:

    Special Instructions

    To take advantage of the full-bleed featured post slider (requires Featured Content):
    1. Create a post with a featured image that’s at least 960px wide.
    2. Give the post the tag you declared under ‘Settings’ > ‘Reading’ > ‘Featured Content’.

    The problem is, I can’t find ‘Featured Content’ either under ‘Reading’ or ‘Customize’.

    Then I checked the codes, and found out the slider.php called the function superhero_get_featured_posts(), which was defined in jetpack.php and jetpack.compat.php:

    function superhero_get_featured_posts() {
        return apply_filters( 'superhero_get_featured_posts', false );

    It seems that no hook called superhero_get_featured_posts had ever been added, so it would obviously return nothing.

    I solved this problem by adding the following codes in functions.php:

     * Add a filter function which fetchs posts through a specific tag name to the hook 'superhero_get_featured_posts'. It intends to fix the bug of downloaded Superhero theme.
    function get_slider_posts()
        $tag = 'slider';
        $args = array(
            'taxonomy' => $tag,
            'terms' => $tag,
        $postslist = get_posts( $args );
        return $postslist;
    add_filter('superhero_get_featured_posts', 'get_slider_posts');

    Then I added a tag called slider to the posts with featured image, the slider then showed up. But anyway it’s not so elegant, and I’m sure there are some bugs in Superhero 1.1.1, because everything works fine on

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Kathryn


    Automattic Happiness Engineer

    Hi there, could you please confirm that you have Jetpack active? Jetpack is required for the slider to work, but there may still be a glitch right now so it would be helpful if you could confirm whether you have Jetpack installed and active or not. Thanks!

    Thanks you sooooo much! I’m a beginner of WordPress so I didn’t realize that jetpack was a plugin and I didn’t find any hints on this.
    I installed it and activated Carousel, then the Featured Content appeared!
    Thanks again!

    Moderator Kathryn


    Automattic Happiness Engineer

    Great – glad that did the trick!

    We will be working on updating the documentation for this theme so the Jetpack requirement is clearer.

    I have tried everything 100 times, and have searched for help 200 times… I can not find out what is wrong… No “Featured Content” in Customize or Reading… That is my problem… I have Jetpack connected, for it says connected to I try everything over, and over. I just installed everything new and latest versions are for sure. I would appreciate help. tyvm.

    WordPress 3.9 running Superhero theme version
    Ultimate Linux Hosting with cPanel from Godaddy
    I have been supporting computer since 1992.
    Not my first WordPress website or theme, but now for whatever reason I am having trouble. Uninstalled n reinstalled… Major frustration atm.




    I just double checked this with my own install running WordPress 3.9.1, Jetpack 2.9.3, and Superhero, and Appearance > Customize > Featured Content is present in my test.

    @truckingdan, I’m sorry you’re having trouble! Since it’s working for me, I’m not sure what could be wrong with your setup. The first thing that comes to mind is a conflict with another plugin. A basic troubleshooting step to rule that out is to turn off all other plugins and test again. If the Featured Content section appears at that point, then you can turn the plugins back on one at a time to figure out which one is interfering. Is that something you’re able to try out?

    Yes I thought that very same thing, so I did go through and disable other plugins. No luck there, but I plan on starting fresh. Deleting my Database installs, and cleaning folders… Is the scrolling full-width slider part of superhero at the top, or is that not included?




    Is the scrolling full-width slider part of superhero at the top, or is that not included?

    It is included, but it needs the Featured Content code that is built in to Jetpack to work. Jetpack is a dependency for that feature.

    Before you start fresh with everything, you might try completely deleting and re-installing and re-activating Jetpack itself to see if that works first.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘No "Featured Content" in Customize or Reading’ is closed to new replies.