Support » Plugin: ICS Calendar » No events after first month

  • I have a one drive ics calendar, I added the ics to it to the plugin on my site. I added 3 views, month, list and week for testing.

    I can see this months events on my site but if I navigate to any other month from the month dropdown no events are displayed. If I select current month again, no events are displayed, I have to refresh the page.

    I can see the events in coming months in the list view so I know it can see them.

    Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author room34

    (@room34)

    The plugin hasn’t been extensively tested in a scenario where all of these calendars are loaded in the same page. It looks like you may just be experimenting with the different views though and don’t ultimately intend to have the page include them all the way they are now.

    There appears to be a conflict between the month and week views being on the same page — specifically, the week view is messing up the month view, as it’s only showing three weeks, and if I look at the source HTML, I see it has them using CSS classes that should only be in the week view.

    Try removing the week view from your page… I have a feeling the month view will work normally after that.

    I think the problem is to do with layout-specific jQuery in the plugin, that isn’t properly isolating itself to the affected view. Having multiple views on one page is causing the jQuery to interact with a calendar it shouldn’t be altering.

    Anyway… let me know if removing the week view from this page fixes the month view. Thanks!

    Plugin Author room34

    (@room34)

    I’ve just gone through the plugin and made a few changes to limit the scope of some of the jQuery that I think was causing this problem.

    Please update to version 5.3.0 when it becomes available shortly. With these changes you should be able to have both the month and week views on the same page. Let me know if it works. Thanks!

    yeah that fixed it thanks. Just having the month only on the one page resolves.

    And yeah I was putting multiple in to see what it looked like… didnt think that one would be clashing with the other

    thanks

    small further question, the month view I can dropdown only shows the next 6 months but I have events going til end of year, is there a shortcode to get more months in?

    Plugin Author room34

    (@room34)

    If you don’t set limitdays then it should be showing a full year out. It’s possible that your calendar system is only including the next 6 months in the feed.

    Its an outlook calendar, I didnt have limit days, I tried limitdays to 365 but didnt work, still only getting 6 months.

    found this though
    https://answers.microsoft.com/en-us/msoffice/forum/all/view-published-calendar-more-than-6-months-out/e831930a-17b2-4e14-b2d0-b6110bbc8bd3

    I’ll play around with the settings and see if thats changeable for a year. Thanks

    Plugin Author room34

    (@room34)

    Yes, that definitely looks like the issue. Unfortunately since it’s a limitation in the source of the feed, there’s nothing the plugin can do. Hopefully you can get the feed adjusted on your end.

    If you have success, please share the details here, as others may be dealing with the same situation. Thanks!

    quick update on this, I just couldn’t get it to work. I got powershell configured and followed instructions on the display. Not something I wanted to spend time on but hey ho. the default setting as per that link should b 6 months, and it says to set it to One Year but if you go and list the settings which you can, it says “threemonths” to “threemonths”. I set it to one year and confirmed setting but calendar is still only showing 6 months max. It’ll have to do I suppose, not a big thing.

    Now, further question, Im still testing here, in my outlook calendar I created an event with additional details.
    In my shortcode on my webpage I have eventdesc=”true” location=”true” for the events. However in month mode on the site, when I hover over the event and click on it I see the location displayed, but not the additional details. I think this would make sense if eventdesc was taking “the next field” which may be the case on some calendars but in outlook, the next field is location.

    Plugin Author room34

    (@room34)

    You may need to temporarily set reload="true" when you make changes to the settings, just to be sure it’s not still loading cached data from before the change. That should expire within 10 minutes though.

    It doesn’t matter what order the fields are in; they’re all labeled in the ICS file and the labels are what the plugin is using. You may want to check that event in the raw ICS file and make sure it has a DESCRIPTION: line.

    I added debug=true and can see the following fields coming in, seems that outlook has named its “DESCRIPTION” field “EVENTDESC”. Can that be catered for? Thanks for quick response

    [label] => Event
    [eventdesc] =>
    [location] =>
    [start] => 7:00 pm
    [end] => 9:00 pm
    [feed_key] => 0

    Plugin Author room34

    (@room34)

    The debugging is showing the variable names inside the plugin, not the raw data from the ICS feed. If you load your feed URL in a browser, it will download an ICS file. Open that in a text editor and you should see DESCRIPTION:.

    clintsilver

    (@clintsilver)

    ok done that thanks, downloaded the ics and opened in notepad and it has a DESCRIPTION field.
    these are the options I have at the moment in the calendar shortcode

    view=”month” eventdesc=”true” location=”true” toggle=”true” reload=”true”

    If you open that URL I have 2 calendars on it now, both have same issue (same issue even if 1 calendar on the page). Theyre displaying the DTSTART and SUMMARY. I hover over the time, get a question mark, click it, and then I see the DTEND but no DESCRIPTION.

    Plugin Author room34

    (@room34)

    I’m seeing “P1” in the eventdesc hover on the event for 18 February. No descriptions on the others. Is that the only one that has a description in the feed, or do the others as well?

    clintsilver

    (@clintsilver)

    The others have descriptions, Im wondering if its the version of WP, it needs to be updated I think as Ive just noticed the plugin says its incompatible with the version Im on. Ill try to update and see does it still happen. thanks for help so far, I’ll reply after Ive updated. thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.