Support » Plugin: WP Scroll Depth » No event fired – GA via Tag manager

  • Hi there,

    installed the plugin, code added to source correctly, no errors in the debug. But the events are not fired in GA.

    We’ve implemented GA tracking via the tag manager. How does the plugin make that connection to our GA account if GA is added via tag manager (as the GA account number is not in the source code…).

    Thanks a lot,
    Sebastian

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor lonkoenig

    (@lonkoenig)

    With Google Tag Manager, you enter your ID when you set up the Analytics tag.
    The plugin should recognize that you’re running GTM and use the GTM method for sending events: DataLayer.push().
    The Analytics object already knows your ID.

    How are you testing for events?
    I usually pull up the Analytics Reporting for the property then watch the Real-Time:Event graph.

    It sounds like you’ve already done the troubleshooting from the FAQ.

    Make sure the Trigger for your Analytics tag is firing on the page where you want to record events. (Usually you fire the main Analytics tag on every page.)
    GTM screenshot
    (Since we do a lot GTM work, we define a variable “universal_analytics_id” so we don’t have to copy-and-paste the ID into multiple tags.)

    And, of course, make sure you’re looking at the right property when looking for events. I was beating my head against missing events last week when I realized I was using the ID from a test property. Doh.

    • This reply was modified 3 years, 1 month ago by lonkoenig.
    • This reply was modified 3 years, 1 month ago by lonkoenig.

    Hi, thanks a lot for your quick answer.

    – Our GA tag is firing for sure (we’ve got about 4 million users per month on our site…so GA is set up correctly for sure as we have been using that for more than a year with the tag manager).

    – Right –> I tested as you described in the live traffic > events. Unfortunately nothing is tracked here. If you’d like to have a look, this is our site http://bit.ly/2je3S26 (you can see the source code has the correct code from your plugin).

    Thanks a lot in advance,
    Sebastian

    Plugin Contributor lonkoenig

    (@lonkoenig)

    Just cleaning up support threads. Sounds like you got this resolved?
    Do you mind sharing what the problem was for future visitors to the support site?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘No event fired – GA via Tag manager’ is closed to new replies.