Support » Plugin: Theme My Login » No error messages and field data lost after form submit

  • Hi Jeff

    My register form doesn’t output error messages and the field data is lost after form submit.

    Any idea why this might be?

    My login and password management pages are fine. I’m using the default templates and am outputting the form via a shortcode in my /register/ page.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter Henry Wright

    (@henrywright)

    I have set up a second site but this time I used the Apache web server. Everything is working fine.

    My first site (where I am seeing the problem) uses Nginx. That’s the only difference.

    Hi, same here.
    Login and PW Reset Pages are working fine with ERROR messages.
    The Register site does not show any error messages.
    After entering all data, e.g. a new registration with an already registered email, the form is submitted, NO error messages, the register page is appearing again with empty inputs. I use NGINX as well, no security plugin is working.
    I’ve debugged it local and the $errors object in my theme-my-login-custom.php ($errors->add(‘my_error’, ”)) is filled, but not error is displayed.

    @jeff: I think a lot of people have the same problem. Most of them do not know, that they have this problem, because you see the issue only if you try to register someone with an existing email or with wrong or missing data.

    Would be super cool, if you could have a look on it.
    Thanks and best regards
    MH

    Now I’ve used the original register-form.php from the TML plugin and deleted my theme-my-login-custom.php. But still no errors appears during a “wrong” (e.g. already existing email) registration.

    SOLVED: The UPDATE 6.4.6 of TML overwrites the post_id of my registration site / page in the DB. I think the update creates a new registration page and took this ID. (meta_key: _tml_action, meta_value: register)

    And I had to delete the instance attribute in the shortTag Code of my registration page:

    From: [theme-my-login default_action=”register” register_template=”register-form-my.php” instance=”1″]

    To: [theme-my-login default_action=”register” register_template=”register-form-my.php”]

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘No error messages and field data lost after form submit’ is closed to new replies.