Support » Plugin: Easy WP SMTP » no emails using godaddy

  • Resolved haychart

    (@haychart)


    Hi

    had to move a site to GoDaddy

    created a godaddy email but was told that wont work – read a few answers here and says create a gmail and use settings –

    smtp.gmail.com
    TLS
    587

    its still not working for me – i dont use godaddy – just helping a friend

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, you are probably experiencing the same problem as posted in this thread.

    Kind regards

    i thought that but they are saying not

    Just tried again and now i get

    SMTP ERROR: Failed to connect to server: Connection refused (111)SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    this is using
    smtp.gmail.com
    TLS
    587
    Authentication yes
    username
    password

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, I am not sure how the other person in the forum post I shared above fixed his issue with GoDady.

    I guess the best thing to do would be to ask him. You might want to reply in the above forum post.

    Let me know what the outcome is.

    Thank you

    i did some work on it last night and now i can send from the Test Email tab and receive that email fine

    when i fill in the contact form it says thanks for contacting us – but i don’t receive the email

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, did you check to see if the e-mail is landing in your spam folder? If you don’t mind me asking, what did you do to get it working? The reason why I am asking is to help those who run into a similar situation as you while using GoDaddy.

    Thank you

    It now works completely

    Although it did come with {Spam?} heading

    i don’t know if there was an error somewhere or it just needed time for settings to take effect

    SMTP Host – localhost
    Encryption – None
    SMTP Port – 5
    Authentication – Yes
    then cpanel email and password

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, I am happy to know that it is working for you.

    I am marking this thread as resolved.

    GoDaddy employee posting from a personal account here. There was a typo in haychart’s post. Those settings are for cPanel but he made a mistake on the port. The correct settings are:

    For cPanel hosting:
    SMTP Host – localhost
    Encryption – None
    SMTP Port – 25
    Authentication – None

    For every other hosting type:
    SMTP Host – relay-hosting.secureserver.net
    Encryption – None
    SMTP Port – 25
    Authentication – None

    Connecting to outside servers on standard mail ports is a security policy GoDaddy won’t change for shared hosting. You’d need to use a provider that supports port 80 or an API, which is usually one of the reputable delivery services like sendgrid.com or mailgun.com

    • This reply was modified 1 year, 10 months ago by bsweaney.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘no emails using godaddy’ is closed to new replies.