Support » Fixing WordPress » No edit toolbar on "Edit Page" screen. Anyone else?

  • Not sure when this “bug” appeared, but I know it’s recent.

    For some unknown reason, I no longer have a formatting toolbar above the text input box on my “Edit Page” page (you know, the “B”, “I”, “link”… buttons?)

    When I edit my sub-pages, the formatting toolbar has disappeared. Not sure when, but it’s recent since I edit these pages frequently yet only discovered this change recently. Anyone else have this problem?

    Not sure when they disappeared or why, but I know it’s recent. I’ve been using the same theme (of my own creation) for over three years, so it’s not my theme (or something new was changed to break my theme), and I’ve tried disabling my plugins, to no avail.

    I can’t disable my theme to test because the site is under constant use, but I doubt it’s my theme anyway. This “bug” is a new development that “may” have come about with the most recent upgrade (from 3.4 to to 3.4.1)

    Is this a “bug”? Anyone else have this problem?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Do you have any plugins or any homemade code that may interact with your page edit page? This might cause some compatibility issues because of the update to 3.4.1.

    It wouldn’t hurt to check your theme too. Copy your files over to a subdirectory and install a second WordPress (still tied to your database), kinda like a sandbox directory. From there you can disable the theme to better pinpoint the source of the problem.

    Thanks for the reply patv, but I’ve already tried disabling all plugins, and as noted, am not in the position to disable/change my theme even momentarily.

    If you aren’t also experiencing the glitch, then it must be something new on my end. Any chance there’s a WP setting I might have missed that would disable this?

    I’d also check your features.php file, to see if you’re coding anything remotely near the post edit page.

    Other than that, you might want to look at wp-admin/edit.php and see if it has been modified recently. If not, go through its code and look at all the files it is including or calling (through function calls) and see if they have been modified since you have installed WordPress. The idea is that perhaps one of the core files have been modified since its installation and you’d need to revert this back.

    There’s no “features.php” file in my site. Or maybe I’m just not seeing it. Where would I find it.

    Only my theme has been modified, not the core files in other directories. My “edit.php” file has the same date as the other core files (6/15/2012), so I don’t believe it has been modified without my knowledge.

    Can you recommend a good “Down for Maintenance” plug-in that works with the most recent version of WP (3.4.1)? The ones I’ve tried so far didn’t work. I can use one to disable the site long enough to try disabling my theme for testing. Thx.

    It would be found in your themes folder.

    And no idea for a ‘Down for maintenance’ plugin. If you want just a static page, you can rename the index.php file at your root folder (to anything not index.php so it doesn’t get called by default, so for example, index_old.php) and create a new file called index.html (still at the root folder) where you can write a simple web page mentionning it’s down for maintenance.

    Nope, no “features.php”. Not part of the theme I used as the basis for my customized theme.

    I have a hand-made index.html “Down for Maintenance” page, but that only works if people come in through the front door. Anyone visiting my blog via a story link would still get into the site. That’s why a plug-in is needed to disable the entire site.

    I’ll just wait until around 2am before disabling anything for testing.

    If your .htaccess is installed properly, all URL requests should be redirected through /index, no?

    Well, I found the problem (I guess), and it is indeed a “bug”… so to speak.

    Turns out a “Page” I’ve been working on (a list of links) has become so long, the editor is choking on it.

    I disabled all of my plugins and was reactivating them one by one, then reloading my Page to see if the Formatting Buttons would reappear. Repeatedly reloading the long page was a little slower than necessary, so I tried instead loading a much shorter page, and the buttons appeared just fine. I tried several other pages and the buttons loaded just fine with those pages too. Only my longest Page (556 lines) results in the formatting buttons not appearing.

    So at some point fairly recently, the page grew so long it started preventing the formatting toolbar from loading. I have no idea why, but at least now we know the cause. Hopefully, someone will figure out why and correct it in a future update.

    Same thing has happened to me- no formating toolbar when I try to add content or a new page – but I haven’t even got 5 lines on the page! Help??



    Forum Moderator

    @heenad – if you need help, you should start your own thread rather than tacking on to an old one. Please also include relevant information in your post – per

    Thanks @wpyogi – first time here!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘No edit toolbar on "Edit Page" screen. Anyone else?’ is closed to new replies.