Support » Fixing WordPress » No "edit this" box on new pages that I create

  • Resolved jerryisaacs


    Since I changed to the latest version of WordPress, whenever I add a new page, the click box for “Edit This” no longer appears. So then I have to go to my home page (which I can edit via the “Edit This” box) and then try to find the right page in order to edit. How can I fix this?

    My website is

    If you click on the RH Repertory link, you will see that the “Edit This” option is not visible.

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    De-activating all plug-ins triggers this message:
    Warning: implode() [function.implode]: Invalid arguments passed in /home/content/97/4192497/html/wordpress/wp-content/plugins/wp-super-cache/wp-cache.php on line 2612
    Warning: implode() [function.implode]: Invalid arguments passed in /home/content/97/4192497/html/wordpress/wp-content/plugins/wp-super-cache/wp-cache.php on line 2613

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/97/4192497/html/wordpress/wp-content/plugins/wp-super-cache/wp-cache.php:2612) in /home/content/97/4192497/html/wordpress/wp-includes/pluggable.php on line 881

    The problem persists.

    Switching to the Twenty Eleven theme does not resolve the problem.

    Not knowing how to reset by FTP or PhpMyAdmin, I called Godaddy and asked them to reset my plugins folder. I was walked through the process to delete the plugins folder, to no avail. The problem persists.

    My plugins were
    Google XML Sitemaps
    Revision Control
    WP Super Cache WP Super Cache



    Forum Moderator

    Create a fresh plugins folder and move the wp super cache folder back into this new folder. Then, if necessary, read up on how to deactivate WP Super Cache.

    After I removed all the plugins and the plugins folder, the problem persisted. Thus I concluded that since the issue persists with the plugins totally purged from my website, further messing with the plugins cannot possibly resolve the issue (or make it worse).

    Accordingly, before I received your latest reply, I proceeded an hour ago to install new versions of all of the plugins. I reiterate that the problem persists, with or without the plugins.

    Please let me know if you still believe that messing with the plugins can help me. Otherwise, I would prefer not to go through the effort of juggling all of the plugins again.



    Forum Moderator

    Cache plugins are always a very special case. You need to follow the instructions for deactivating them via the WP back end if you can. Failing that, try creating a folder called plugins-holding and move all of the folder in wp-content/plugins across to this new folder – with the exception of the wp-super-cache folder. Let’s see how that goes.

    Any joy when you renamed your theme’s folder?

    Per my posts above, I deactivated the plugins through GoDaddy’s interface per your recommendation to use FTP or PhpMyAdmin. That didn’t solve the problem. I don’t know what you are referring to as the WP back end. I am a retired mechanical engineer-not a web-admin geek. Again, my impression is that if I purged all the plugins and that didn’t solve the problem, “plugins ain’t the problem”. I think the problem is WP’s latest update, because I haven’t had a problem with this website for the last five years or so, until I upgraded to WP-3.4.

    It is exasperating to try to find the right page to edit without the little ‘Edit This’ box at at the top of every page when I am logged in as administrator.

    I re-iterate – I completely removed the plugins. I didn’t just deactivate them. So then I installed the updated plugins. If you have the slightest notion that removing them again will help, I will do so, but I will have to call GoDaddy again and get somebody to help me jump through all the hoops on their ransom-note-like website.



    Forum Moderator

    I don’t know what you are referring to as the WP back end.

    The Admin area. The place where you write Posts and change themes etc.

    Again, my impression is that if I purged all the plugins and that didn’t solve the problem, “plugins ain’t the problem”.

    Not quite. As you happened to be using a caching plugin, moving/purging it created a second, unrelated, problem which simply masked the original one.

    I think the problem is WP’s latest update

    speaking as someone who does a lot of WordPress support, I have to say that this is been one of the smoothest updates for a long time. So far, all of the issues that we are seeing have been due to incompatible plugins and/or themes with the odd corrupt download here & there.

    I changed the name of my plugins folder to plugins_obsolete. Then I moved the WP-supercache folder to a new folder called plugins. Then I de-activated WP-supercache. An index.php file is still in the plugins_obsolete folder.

    I still cannot conveniently edit the page
    Because the “edit Now” link does not show up even when I am logged in as admin.

    Any new pages that I create are similarly inaccessible for convenient edit.

    What’s next?

    It’s interesting that I can edit old pages and that no problem occur to impede additional edits. Only newly-created pages do not display the “Edit This” box.



    Forum Moderator

    Try switching to the Twenty eleven theme.

    Using 2011 theme (latest version) and WPsupercache disabled, the Edit link that appears on the HOME page does not appear for page (i.e., the problem persists) WP-super-cache is the only folder in the /wordpress/wp-content/plugins folder.

    I have put screenshot links on my homepage for you to look at.

    AHA: A key might be related to the fact that the homepage url includes the wordpress directory:

    My old page for chess resources also includes the wordpress directory:

    whereas the new rh-repertory page does not.

    So it appears to me that for some reason my pages are now being stored in a different location than they were previously stored. If you concur, please advise me how I might proceed to correct this problem.


    All I needed to do was revise my link code to include the wordpress folder. I believe the problem has been solved. Thank you for your help.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘No "edit this" box on new pages that I create’ is closed to new replies.