Support » Plugin: WordPress Shortcodes Plugin — Shortcodes Ultimate » No default border in su_note after update to 3.4

  • Resolved Patryk

    (@prcpl)


    Hi

    After update to 3.4.* note module (su_note) missing default border (#333333). Before 3.4.* work this shortcode:

    [su_note note_color="transparent" radius="0"]Some text[/su_note]

    Now no border, also with text_color=”#333333″.

    Best regards, patryk

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Vova

    (@gn_themes)

    Hi Patryk,

    sorry for the late reply.

    Prior version 5.4 transparent was interpreted incorrectly. Now it works as it should, it displays a transparent border.

    If you want to add a grey border again, please follow the instructions below.

    1. Add the following code to the end of the functions.php file of your theme:

    function su_add_note_border_css_class( $atts ) {
    
    	if ( ! isset( $atts['note_color'] ) || 'transparent' !== $atts['note_color'] ) {
    		return $atts;
    	}
    
    	$atts['class'] .= ' su-note-with-grey-border';
    
    	return $atts;
    
    }
    
    add_filter( 'shortcode_atts_note', 'su_add_note_border_css_class' );

    2. Then, navigate to Dashboard → Shortcodes → Settings and add the following CSS code to the Custom CSS code field:

    .su-note.su-note-with-grey-border {
    	border-color: #333333 !important;
    }
    Thread Starter Patryk

    (@prcpl)

    THX for reply.
    Because I use only one “note” format (transparent background + border) I use CSS:

    .su-note .su-note-inner {
    	border: 1px solid #333 !important;
    }

    Best regards, Patryk

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No default border in su_note after update to 3.4’ is closed to new replies.