Support » Plugin: Event List » No date, location or time listed anymore, not in order

  • Help! I just upgraded to WP 5.0.3 and updated the plugin to 0.8.3, and nothing seems to be working now. In the events listing, the date, time and location of each event is no longer listed. It’s just the description paragraph that shows up. And the order of events is now listed in the order they were created, with the newest on top. So now it’s extremely confusing for people to read, with the events not showing chronologically. Plus the [event-list] short code leads to a 404 not found. Anyone else having these issues, and can they be fixed? At least the ordering of the events, that’s a big one. Thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • It sounds like you are looking at the archive page for the el_events custom post type rather than the page containing the shortcode.

    Do you have a link we can look at?

    What is your setting under Admin / Event List / Settings / Frontend Settings, “Events permalink slug”?

    This is the homepage, where the events widget in the sidebar is showing correctly:
    http://www.irishcenterwne.org/

    This is the events listing page where the order is wrong and the details are no longer showing up:
    http://www.irishcenterwne.org/events/

    The permalink slug is “events” – it hasn’t been changed.

    Thank you.

    Eddie

    (@ejamesonvalleyhopeorg)

    Have you cleared your page cache? I have had similar issues and it ended up being a cached page conflict.

    Yes, what you are seeing is the archive for the el_events custom post type. Since WordPress doesn’t know about events, it displays them as regular posts.

    What you can do is make a copy of your archive template (if your parent or child theme has that template) and rename it to archive-el_events.php.

    You will probably also make a copy of single.php and rename it to single-el_events.php.

    If you do not have an archive.php or single.php, you can make a copy of index.php instead.

    What happens next, depends on your theme and also on what you want. There are a few options. You could take the loop out of your fresh templates and replace it by shortcode calls, or you could try to influence the display and sort order of your event posts.

    There are several posts in this support forum that deal with this situation.

    A third option would be to disable the archive.

    A fourth option would be to not link to the complete events list, but instead to a page that has the shortcode in it.

    Some threads that may be of interest:

    https://wordpress.org/support/topic/get-date-and-event-location-in-single-el_events/

    https://wordpress.org/support/topic/exclude-events-from-search-2/

    https://wordpress.org/support/topic/archive-single-pages/

    Change the order of the events on the archive page by adding the following within PHP tags before the loop:

      $settings = array();
      $today = date('Y-m-d');
      $type = 'el_events';
      
      $settings = array(
        'post_type' => 'el_events',
        'post_status' => 'publish',
        'ignore_sticky_posts'=> 1,
        'thumbnail' => true,
        'order' => 'ASC',
        'orderby' => 'meta_value',
        'meta_key' => 'startdate',
      );
    
      $meta_query_default = array( 
            0 => array( 
                  'key' => 'enddate',
                  'value' => $today,
                  ), 
            );
      $meta_query = $meta_query_default;
      $meta_query[0]['compare'] = '>=';
      $settings['meta_query'] = $meta_query;
      
      $wp_query = null;
      $query = new WP_Query( $settings );

    Forget all I said, way too complicated.

    You need to do the following:

    1. Create a new page.

    2. Put the events-list shortcode of your choosing on this new page.

    3. Put the link to this new page in the field “URL to the linked Event List page” in your front page widget.

    That should make it work.

    If you want the path for the new page to be ‘events’, you can change the path for the Event List custom post type archive page in the Event List settings, so that the path ‘events’ is freed up for your page.

    wpkatie

    (@wpkatiedoe)

    Thank you! I was hoping it was something simple like that. For the time being, I had removed the events list link from the website to avoid confusion. After reading all the replies, I went in today and checked the page and the shortcode – I still hadn’t made any changes, but the listing was now showing up correctly again. Thanks for the replies.

    Thanks @hatesspam your workaround has worked for our event listing page : )
    Any ideas how to get it to work on the home page as we have used the short code [event-list num_events=2┬ácontent_length=20]in the home page but when you click on the links they don’t go anywhere just back to home page.
    Thank you : )

    Do you have a link?

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.