Support » Plugin: WooCommerce » No database update feasible

  • Resolved bulls_shark

    (@bulls_shark)


    Hello dear support team, I have the problem with 4 websites that I can not update the database. There is no link as usual at the top.

    On the internet I found the link: wp-admin / admin.php? Page = wc-settings & do_update_woocommerce = 1 this does not work. I get the message: The link has expired.

    I checked the status and the database is on the old version.

    WooCommerce version: 3.5.0
    Database WooCommerce Database Version: 3.4.7

    I disabled and re-enabled plugins. Without success.

    Do you have a solution for me? Thanks for your time and support!

    Thank you

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Claudiu Lodromanean

    (@claudiulodro)

    If you have WP CLI available you can run the command wp wc update to run the updater. Hope this helps.

    bulls_shark

    (@bulls_shark)

    Hello Claudiu Lodromanean, thank you very much for the quick response. Unfortunately, I do not know myself with WP CLI or I have never used it.

    Will read it tomorrow and try.

    Best regards

    bulls_shark

    (@bulls_shark)

    Hello there is still another solution to fix the problem?

    Thanks for the support!

    Hello dear support team I tried a lot to update the database unfortunately without success.

    With these messages I get the following:

    The parameter “wc” does not seem to exist:
      
    Error: ‘wc’ is not a registered wp command. See ‘wp help’ for available commands.
    Did you mean ‘db’?

    When I run “wp core update-db” in the directory of your WordPress instance I get the following error:
      
    PHP parse error: syntax error, unexpected ‘?’ in phar: ///var/www/vhosts//bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php (1150): eval () ‘d code on line 1

    The plugin I have already disabled and enabled without success. With the last update I deactivated all plugins except for Woocommer without success.

    I look forward to your support!

    Thank you

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hi @bulls_shark,

    Sorry for the delay in getting back to you.

    On the internet I found the link: wp-admin / admin.php? Page = wc-settings & do_update_woocommerce = 1 this does not work. I get the message: The link has expired.

    This functionality has now been removed.

    Can I ask, did/do you see an admin notice similar to this – https://d.pr/tOAdN9

    If so, you can use this.

    Can you let us know who your host is, there have been other reports of this behavior where the admin database update notice was suppressed and we are also looking into adding other checks to make sure this doesn’t happen in future.

    As both version 3.5.1 has been released, have you been able to update to this and upgrade your WooCommerce database using the admin notice in my screenshot?

    Let me know how you get on!

    Thanks,

    Hello thanks for the support, the problem lies with the template I assume “Porto”, after I changed it against a standard theme came also the message for the database update. I reported it to the developer there, he had access to the system, what exactly changed it, I can not say.

    Best regards

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @bulls_shark

    after I changed it against a standard theme came also the message for the database update

    Can you let me know if you have been able to run the database update after updating to WooCommerce 3.5.1?

    And yes, often theme files will become outdated. You can read more about this here – https://docs.woocommerce.com/document/fix-outdated-templates-woocommerce/

    Thanks,

    Hello yes, everything is now up to date. Maybe you can include an option under Status – Werkzuge, which can be started later with such errors by hand later? Thanks for the support and your time!

    Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Hey there,

    I’m glad to hear you were able to update!

    Please do add that recommendation to our ideas board: http://ideas.woocommerce.com/forums/133476-woocommerce

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.