Support » Plugin: Gravity Forms: GDPR Add-On » “No data stored…” in response email

  • Resolved rku4er

    (@rku4er)


    Hi there,

    I have a question. I used this plugin on my site and I have noticed that after I configured the GDPR Framework and have this Gravity Forms add-on activated the requested user data can’t be managed: I simply got “no data stored…” email(but I can see my data record in dashboard Forms->Entries). But when I went to the Form settings -> Privacy and just clicked updated the settings there – all the next emails contained the links to privacy data edit page(like this: http://mysite.com/privacy-tools/?gdpr_key=lQwgKzrYlYwyO9ViznPn&email=mailbox@domain.com).

    Please let me know if I missed something and it is already documented.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I have seen the exact same problem.

    I did a test where I filled out a form with a specific email address and then tried the tool to see what it returned.

    I got the response that there was no data stored.

    I have just done the very same test. Got the very same result.

    “No Data Stored”… when you login to WP Dashboard you can see all the test form results and Approved Blog enteries. So the is data, but WP is not presenting the data back to the privacy tools page.

    This is needed to be fixed as customers will not be able to access data, and to change preference, and delete data as per GDPR compliance requirements.

    I have an update for those who have this issue happening for a unknown reason: it’s most likely a caching issue. It works well to me since I asked my the support(wpengine) to exclude /privacy-tools page from a caching scope.

    I excluded the /privacy-tools page from WP-Rocket and that did not solve the problem for me.

    1. Please, make sure you excluded the exact page URL you configured as Privacy Tools Page [dashboard->tools->privacy->general]. This fixed no email issue to me
    2. Make sure you updated Gravity Forms Privacy Settings [dashboard->forms->settings->privacy]. This fixed “no data stored” emal issue to me.
    • This reply was modified 1 year, 5 months ago by  rku4er.
    Plugin Author indrek_k

    (@indrek_k)

    @rku4er thanks again for helping out others!

    @yowinternet @masterk did you manage to get the plugin working?

    Yes. Thank you.

    Just waiting for WooCommerce next. Will this be done before 25th?

    Plugin Author indrek_k

    (@indrek_k)

    I’ll do my best to get at least the tracking of T&C and PP consents given via Woocommerce checkout working. As for anything else, I literally haven’t even had the time to test the new WooCommerce release so I’m not yet sure what exactly we’ll need there. So much work to do 😐

    Steve

    (@stevielovegun)

    Hi,

    Thanks for a super-useful plugin in this busy time 🙂

    I was having the same issue and, as noted by @rku4er, fixed it by updating the settings for the form ( forms > myform > settings > privacy).

    My hunch is that although this privacy settings page appears for each form when the plugin is activated it doesn’t actually begin to work until Update Settings is clicked (even if no changes are made to the options).

    Plugin Author indrek_k

    (@indrek_k)

    @stevielovegun is correct – you need to update the privacy settings and pick a field to be used as the main email address. Otherwise, the plugin won’t know how to identify the data.

    I should probably display a notification if a form is not configured properly.

    Steve

    (@stevielovegun)

    Aha, thought so @indrek_k.

    A notification would be useful I think.

    Thanks again for your great work.

    Thanks for you help guys. Seems it’s clear now how the things going 🙂 I only think it may be a good idea to pick the first email field if available in privacy settings.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘“No data stored…” in response email’ is closed to new replies.