Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » No data sent to Google Analytics

  • Resolved melebius

    (@melebius)


    I have set up Complianz on my website and let it manage Google Analytics (GA). I have opted in to anonymize IP (checked all 3 checkboxes) and entered my G-*** tracking code.

    GA shows me just 2 users visiting my website on September 27 (when I set up GA) but no one after that. I am pretty sure people (including me) do visit the website as there were 3 orders made using WooCommerce in the meantime.

    Things I have done to troubleshoot this issue (used hints from https://holini.com/google-analytics-isnt-working/, among others):

    I’ve run out of ideas… What can I do to get Google Analytics working through Complianz?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @melebius,

    I can’t check the implementation if Complianz is disabled. PLease enable, so I can have a look. You should look for this script:

    <script type="text/plain" async class="cmplz-script cmplz-stats" src="https://www.googletagmanager.com/gtag/js?id=G-R****TMHRC"></script><!-- Statistics script Complianz GDPR/CCPA -->
    					<script type="text/plain" class="cmplz-stats">window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'G-R****TMHRC', {
        cookie_flags:'secure;samesite=none',
    'anonymizeIp': true
    });
    </script

    Let me know, we will have a look,

    regards Aert

    Thread Starter melebius

    (@melebius)

    Hi @aahulsebos,

    Thanks for your prompt reply. I do have Complianz enabled all the time on the production site. I have got the script you mentioned at the end of my webpage source code but as I’ve written before, its first line is missing…

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @melebius,

    Complianz doesn’t seem to be active on the front-end. Is it possible that Complianz detects that this site does not need a Cookie Banner, because there are seemingly no non-functional Cookies being set? I attach a screenshot below to illustrate this: Schermafbeelding-2021-10-05-om-16-56-03

    Could you confirm that you have 100% completion in the Complianz Dashboard, and that a notice appears stating that “your site needs a Cookie Banner, which has been enabled”?

    Let me know if you have any additional information about this.
    Kind regards,
    Jarno

    Thread Starter melebius

    (@melebius)

    Hi @jarnovos,

    You are right, I haven’t mentioned that Complianz detected I do not need a Cookie Banner, so it was disabled automatically. That was true with Complianz 5.4.

    However, today I upgraded Complianz to 5.5.1. With the same settings, the Cookie Banner started to display. After I accepted statistical cookies, GA started to recognize my visit.

    So my initial problem seems to be solved but I’ve got a follow-up question: Is it no more possible with Complianz 5.5 to use Google Analytics (with IP anonymization) without a cookie banner?

    “In some countries, like Germany, Austria, Belgium or Spain, consent is required for statistics, even if the data is anonymized.”
    I am located in the EU but have selected that I am not targetting mentioned countries in the Complianz wizard.

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @melebius,

    Thank you for providing this additional information.

    We have created a fix for this. Could you try installing this updated version (replace the old version on your site, when prompted), and let me know whether this fixes the issue on your end? https://we.tl/t-6okcqfQtZJ

    Just let me know if you have further updates.
    Kind regards,
    Jarno

    Thread Starter melebius

    (@melebius)

    Hi @jarnovos,

    I installed the updated version on my website today and went through the wizard again but nothing changed from my perspective – Complianz still shows a Cookie Banner and blocks statistical cookies by default.

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @melebius,

    I had tested this version locally, with the exact same settings that were used before I had applied the update. No banner shown, and Analytics firing as you would expect (while previously, no banner was shown and no analytics fired). If a banner is now displayed, that would indicate that something in your Settings has changed since the last time.

    To troubleshoot this, it would be helpful to test with the same settings that you are using. Could you send an email to support(at)complianz.io, and attach an export of your Complianz Settings?

    Kind regards,
    Jarno

    Thread Starter melebius

    (@melebius)

    I sent my Complianz Settings export to the support email and got a useful hint: I had turned on “Do you want to ask for consent for Statistics?” by a mistake. The problem is solved now.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.