Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » “No data returned” with Google Photos

  • Resolved davetavres

    (@davetavres)


    Hi there…

    I setup the OAuth following the instructions, and got the “Refresh Token (for Back-end / Server-side Authentication)” setup and saved.

    When I’m on a post, and click the “Add / Edit Photonic Gallery” button (above the edit textarea), I’m prompted with “Choose Gallery Source”, to which I click on “Google Photos” and click the blue “Next” button at the bottom-right corner.

    On the next screen – the “Choose Type of Gallery”, I’ve tried all three options for “What do you want to show?*” – “Multiple Photos”, “Photos from an Album”, and “Multiple Albums” – but when selecting ANY of those options and clicking the blue “Next” button, I always get the same error at the top of the Photonic Gallery – “No data returned”

    I don’t know what that means… and I don’t see any other help online.

    Anyone have any tips?

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Sayontan

    (@sayontan)

    Does your site have cURL enabled? You might have to check with your hosting provider to verify this.

    Plugin Author Sayontan

    (@sayontan)

    One more thing – can you go to Photonic → Settings → Generic Options → Generic Settings → Turn off SSL verification in calls, and turn it off? If this works, it might be worthwhile talking to your host to see why you are getting an SSL error with your certificate.

    jplamb

    (@jplamb)

    I am getting exactly the same, and have done the same as OP. turning off the SSL verification didn’t fix it.

    Sorry OP for jumping in – thought it best to add my comment as it may be a bigger issue and not be your setup

    Plugin Author Sayontan

    (@sayontan)

    @jplamb,
    It is normally advisable to start your own issue for these even if the issues look similar. In any case, have you checked with your provider about cURL?

    jplamb

    (@jplamb)

    @sayontan – i will start my own issue now, cURL is enabled

    davetavres

    (@davetavres)

    Same result as jplamb – I have checked the “Turn off SSL verification in calls” box (When selected, Photonic will not use SSL verification for secure calls. This is not recommended, and may only be used on development sites.) but I still get the same result – “No data returned”

    I checked with SiteGround (the webhost), and cURL is enabled.

    I’ve also tried deleting, then re-installing the plugin.

    Am I missing something? 🙁

    Plugin Author Sayontan

    (@sayontan)

    Hi,
    On jplamb’s thread it turns out that one of the steps in the client ID setup was not complete. Can you go through the steps here and ensure that the “Photos Library API” is activated?

    Plugin Author Sayontan

    (@sayontan)

    @davetavres,
    Were you able to check if you have enabled the Photos Library API as per the documentation link in my post above? My belief is that should help your UI run smmoothly.

    Plugin Author Sayontan

    (@sayontan)

    Hello @davetavres,
    Following up here. Were you able to resolve this?

    Plugin Author Sayontan

    (@sayontan)

    I am marking this thread resolved as I believe the fix proposed worked for jplamb. If you still require assistance please reopen this thread.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘“No data returned” with Google Photos’ is closed to new replies.