Support » Plugin: WPF-jqGrid » No Data Display

  • Resolved michael walker


    Thanks for the plug-in – just what I was looking for. I tried the phpGrid plug-in but the lack of documentation or support was a bit disappointing. I’m having the same problem as a previous poster, in that I’ve installed the plug-in, set it up according to the instructions and am using the pre-supplied shortcode/table as a test. I can see the grid displayed, with field headings shown. I noticed that although the table exists in my db, it has no records. So, I added my wp_users table to the allowed list – this has over 500 records – and adjusted the shortcode accordingly. However, I still see no data in the grid. The field names are showing up, so the plug-in is clearly accessing the database. The only thing I noticed – and this probably isn’t relevant – is that the table you provide is ‘wpf – xxx@ whereas the plug-in is actually called ‘wp_f xxxx’ – notice the difference where the hyphen is. I can’t see why that would matter, but thought I’d mention it. I also tried adding a row, but with no success. (i.e. clicked the ‘add row’ button – nothing happened)

    Again, thanks for what looks like the start of a really great plug-in.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author faina09


    Sorry for the delay answering, I do not know why but I am not notified of new support requests!!

    The problem is surely in the jscript generated, because as you correctly pointed if the header are displayed the table is correctly accessed, and the shortcode is right.
    Please send to me the source code or inspect it with firebug or a similar code and let me know!

    Thank you for your reply. I think I may have found something: My WordPress installation is not in the root folder of my site, instead it is in a sub-folder. And I find this message in the code: `

    <title>404 Not Found</title>
    <h1>Not Found</h1>
    <p>The requested URL /wp-admin/admin-ajax.php was not found on this server.</p>
    <address>Apache/2.2.3 (CentOS) Server at Port 80</address>

    This looks as though the script is looking for ‘admin-ajax.php’ in a folder which – on my particular set-up – does not exist. The ‘requested URL’ shown above should actually read: /wordpress/wp-admin/admin-ajax.php -that is the path to this file on my server. Does that help at all?

    Plugin Author faina09


    Yes, his is a BIG help and means there is a weakness in my code. I’ll fix it this evening, stay tuned!! Thanks for the debug and sorry for the issue

    Plugin Author faina09


    Version 0.09 released, hope this fix your issue.

    Thank you – I’ve installed the update and my data is now visible. Again – many thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No Data Display’ is closed to new replies.