WordPress.org

Forums

No CSS or theme (9 posts)

  1. way_2_hot_a
    Member
    Posted 4 years ago #

    CSS is not showing up in browsers, only on localhost.
    using a wamp server, which is in online mode

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Don't use localhost as part of your site url.

  3. way_2_hot_a
    Member
    Posted 4 years ago #

    I'm not using localhost as part of the site url. when it type in my site http://www.mysitehere.com it communicates with the server, but doesn't show any of the CSS/images. but when i enter the same URL "my domain" on the server it will load css, like some kind of permissions problem or something

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    You need to configure your server to redirect all calls to http://www.mysitehere.com to mysitehere.com.

  5. way_2_hot_a
    Member
    Posted 4 years ago #

    How to do this in wamp?? Never had to do this when i installed apache and all last time. Then again i wasn't using wordpress

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    Add yo your .htaccess file:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www.somesite\.com$ [NC]
    RewriteRule ^(.*)$ http://somesite.com$1 [R=301,L]
  7. way_2_hot_a
    Member
    Posted 4 years ago #

    I clicked on the wamp icon, went into apache, then went into alias directorys then selected the only alias there which was named local host, opened the .htaccess file which wasn't even created by default then entered the following code below which as my actual domain in it.

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www.prizesarefree\.com$ [NC]
    RewriteRule ^(.*)$ http://prizesarefree.com$1 [R=301,L]

    1. http://img208.imageshack.us/i/access2.png/ <did this
    2. http://img525.imageshack.us/i/access3.png/ <then this
    3. http://img547.imageshack.us/i/accesspic.png/ <still end up with this

  8. esmi
    Forum Moderator
    Posted 4 years ago #

    Check the css/stylesheet url in the source code of your pages.

  9. delsey
    Member
    Posted 4 years ago #

    I just had this problem. In your blog general settings make sure that WordPress Address and Site address are of the form:

    http://mywebserver/mysite/wordpress

    NOT

    http://localhost/mysite/wordpress

    localhost will be resolved to the LOCAL machine which will only work on the machine running the webserver.

Topic Closed

This topic has been closed to new replies.

About this Topic