Support » Plugin: Last.Fm Records » No Contents (but debugging looks ok)

  • Resolved fncll

    (@fncll)


    Not sure if this plugin is being maintained, but here is my issue: on both https://fncll.org/ and a test site https://fncll.org/astratest/ with debugging on, the console indicates no problems:

    last.fm.records: adding css for element #lastfmrecords
    last.fm.records.js?ver=1.0:90 last.fm.records: adding temporary cd covers to div lastfmrecords
    last.fm.records.js?ver=1.0:90 last.fm.records: https://ws.audioscrobbler.com/2.0/?method=user.getrecenttracks&limit=&user=fncll&api_key=81e2fbf93109656d0e9897a542f7a825&format=json&callback=?
    last.fm.records.js?ver=1.0:90 last.fm.records: last fm returned 51 records.
    last.fm.records.js?ver=1.0:90 last.fm.records: set timer to refresh covers in 3 minutes for element lastfmrecords.

    But no content is displayed.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author jeroensmeets

    (@jeroensmeets)

    Hi! Thanks for using my plugin. Did you set a number of covers to display in the settings of the plugin? It seems the value for count is empty.

    Thread Starter fncll

    (@fncll)

    Thanks for the prompt response! I hadn’t set a number, but that doesn’t seem to be it: I tried changing the visual styling settings as well, but same result (as far as display goes). The new console results:

    
    last.fm.records: adding css for element #lastfmrecords
    last.fm.records.js?ver=1.0:90 last.fm.records: adding temporary cd covers to div lastfmrecords
    last.fm.records.js?ver=1.0:90 last.fm.records: https://ws.audioscrobbler.com/2.0/?method=user.getrecenttracks&limit=10&user=fncll&api_key=81e2fbf93109656d0e9897a542f7a825&format=json&callback=?
    last.fm.records.js?ver=1.0:90 last.fm.records: last fm returned 10 records.
    last.fm.records.js?ver=1.0:90
    

    I’ve left the page with the settings “Plain and Simple” and 10 covers for further troubleshooting!

    Plugin Author jeroensmeets

    (@jeroensmeets)

    Hi! Sorry it took me some time to figure this one out.

    After testing the plugin myself with your last.fm username and other setings, it seems the value for Image width (pixels) in the plugin settings is not correct. Could you try and set this to for example 90 (just the number, no px added)?

    Thread Starter fncll

    (@fncll)

    That did it! Thank you so much for your time (and the plugin, of course 🙂

    Plugin Author jeroensmeets

    (@jeroensmeets)

    Wonderful! Thanks for reporting back.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.