Support » Plugin: wp-forecast » No Connection to Weather Provider

  • Resolved JDTravel

    (@jdtravel)


    Hi, I entered an API key from ipstack, selected weather service OpenWeathermap and set the API key (Free version). When I click the link ‘Check Connection to Weatherprovider’ I just get an empty popup box. Please can you help, thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author tuxlog

    (@tuxlog)

    Hello,

    to find out where the problem is please remove the IP-Stack API-Key and disable “Use visitors location” checkbox.

    Then try the connection test again using AccuWeather as the provider. I haven’t added Openweathermap as Provider for the connection test yet (but is in on my todo list).

    Post the output here please.

    Thread Starter JDTravel

    (@jdtravel)

    Hi, yes I removed the IP-Stack API-Key and disabled “Use visitors location” checkbox.
    I set the Weather service as AccuWeather but this API-Key box is then greyed out so I cannot enter an API key. Clicking the Check Connection to Weatherprovider test still returns an empty popup box.

    Thread Starter JDTravel

    (@jdtravel)

    I disable all other plugins and even changed the theme but still not working on my website on a LiquidWeb web server. It did work though on a website on my Siteground server after disabling the Siteground Security plugin

    Plugin Author tuxlog

    (@tuxlog)

    Okay, do you have any errors in the javascript console of your browser?
    Or do you get any other error or warning messages?

    Plugin Author tuxlog

    (@tuxlog)

    Seems to be resolved

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.