WordPress.org

Forums

No confirmation when creating a new blog (9 posts)

  1. ssmedia
    Member
    Posted 2 years ago #

    Hi,

    When users go to create a blog it takes them to a broken page and doesn't show that the blog has been created. However, in 'my sites' it will still show up.

    Then also, when I try to go to the dashboard of that site it will say: "You do not have sufficient permissions to access this page."

    I've made a quick screencast here: http://screencast.com/t/CL9H2QN9

    Hoping someone here knows how to solve this?

  2. Did this ever work?

    What plugins are you using?

    No I'm not watching the screencast :)

  3. ssmedia
    Member
    Posted 2 years ago #

    Hi, still having the issue.

    I'm using many plugins, from 'multisite plugin manager' to 'login image' and more. Are there any particular plugins that might cause this issue?

  4. Any that impact email or user management.

    The best way is to turn them all off.

  5. ssmedia
    Member
    Posted 2 years ago #

    Thanks for the tip!

    I did just that, disabled all and then turned them on one by one while creating new blogs.

    The offending plugin was 'Remove Email Verification'.

    But another strange issue, BBPress is also causing problems. When enabled, after a blog is created it produces this output:

    "Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453

    Warning: Invalid argument supplied for foreach() in /home/pages/public_html/wp-content/plugins/bbpress/includes/core/capabilities.php on line 453
    Congratulations! You have successfully registered a new site."

    Any other suggestions? :)

  6. ssmedia
    Member
    Posted 2 years ago #

    Ah, and I've still got the error of seeing this message "You do not have sufficient permissions to access this page."

    I've logged in as a user and created several sites, seems like I can only access the dashboard of the first site I created on the network...

  7. Reinstall bbPress and WP core files manually. Something went wiggy there.

  8. ssmedia
    Member
    Posted 2 years ago #

    Tried that but it didn't work :(

    Seems like others have had the same problem here but not too sure about how they managed to fix it... create a new page??

  9. You'll have to ask there.

Topic Closed

This topic has been closed to new replies.

About this Topic