Support » Fixing WordPress » No 'comment' option under posts in static page

  • Hey guys,

    I just cannot configure the posts page. I’ve selected static page for posts as “posts” and there it is. The problem is that after clicking “posts” there is no comment section and I cannot click on the post neither, to “open” it.

    The problem is that “posts” are in “page_id=50”

    And the posts are for example “/?p=92” or “/?p=78”.

    I feel sorry for asking such a stupid question, I just can’t configure it properly because I got use to use themes for money. This one is free and – how to do such a simple thing?

    Address: http://tomwojcik.com/

    Many thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • So commenting is enabled (Settings->Discussions)?

    You can also enable/disable comments on specific pages/posts by going to the page/post editor and up at the top of the screen there is a tab called “Screen Options”. Select Discussion and a new panel will show up in the Editor screen to allow you to enable/disable commenting on that specific page/post.

    Thanks for your answer.

    Yes, it is enabled. I tried all of the combinations.

    There is a possibility to comment a single post, but whenever I go to “posts” card (static page) – there is no option to choose one of the posts to comment.

    1. Website: http://tomwojcik.com/
    2. “Posts”: http://tomwojcik.com/?page_id=50 <– cannot comment
    3. Single post: http://tomwojcik.com/?p=92 <– able to comment

    And I can access the 3rd option only via Admin Panel. How to make it possible to comment in the 2nd “Posts”?

    If you use a default theme (like twentyfifteen) do posts and commenting work correctly then? If so, the issue may be with the theme and I would suggest contacting the theme developer for support.

    Yeah, I have problem like that only with this theme. I just thought that I can configure it easily. I’ll do that.

    Thank you for your answer.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘No 'comment' option under posts in static page’ is closed to new replies.