Support » Themes and Templates » No comment form on pages, even if “Allow Comments” is checked.

  • It took me a while to figure out that the default Kubrick theme won’t show the comment form on pages, even if I check the “Allow Comments” box when writing the page. For now I’ll work around this by tweaking the theme myself. I’m curious if any progress being made on fixing it in a future release, though.

    I found an entry in trac about it (http://trac.wordpress.org/ticket/3753) but it is closed as wontfix.

Viewing 2 replies - 1 through 2 (of 2 total)
  • There is nothing to “fix”! That’s a feature. I’d never want people to put comments on my Contact Page or About Page etc.

    Yes, you need to tweak your theme if you want comments on Pages (or on certain Pages). Meaning you need a Page Template that has the call for the comments template. Look how it is done in the single.php.

    Sorry folks, this is a bug! There is a very clear check box in the page editor that says “Allow Comments” for the page (in fact it is the first check box in page settings). As the Default theme for WordPress, Kubrick should honor this exposed setting in the interface OR provide some kind of feedback in the editor so you know it’s going to ignore it.

    I don’t want to come off as too harsh here, but WordPress has way too many issues like this. They really must be categorized as bugs because people are wasting hours figuring them out. I had the same thing happen with Page Order numbers—you have to drill down into a menu inside the Pages Widget and explicitly tell it “Pay attention to Page Order”!

    Admittedly, I’d find the lack of feedback in the page editing UI a bit easier to stomach if I had gone into the theme preferences at some point and checked a box that said “Ignore Comments Setting for Pages” or “Ignore Page Order”. Then if I got confused later, I could at least feel a little like it was my fault. But a fresh install of the default theme must honor all the parameters (or give a visual cue that it isn’t going to).

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No comment form on pages, even if “Allow Comments” is checked.’ is closed to new replies.