Support » Fixing WordPress » no Comment Form Cookie Consent on wp 4.9.6

  • Hello,
    I just upgraded for the new version oh wp 4.9.6, but after checking, I found out that I don’t have the box under the comment section for the cookie consent.
    Can some one help please?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Marius L. J.

    (@clorith)

    Hi,

    Please see https://wordpress.org/support/topic/read-this-first-wordpress-4-9-master-list/#post-9687602 which covers this, as there are various scenarios where it will not show up.

    thank you for your answer, but The link you gave me is 6 months old. My problem is related to the new version 4.9.6 for the new regulation GDPR after the update I cant see the box that people have to check to accept to share their informations

    Just to confirm this, I can see this issue in some, but not all themes.

    Checking those themes I see nothing special, and they use WP native comments templates.

    What I saw, is that after you reload your website several(!) times, and clear cache, and update the version number of that Theme, and wait over an hour, then it suddenly starts to work.

    Strangely this does *not* happen with every theme.

    I wonder if there may still be some issues with the core updates.

    I will observe if I see this issue repeating and try to fetch the cause.

    @amourdecuisine what exact theme do you use?
    Can I get it somewhere to test with?

    It works just fine if you use Twenty Seventeen theme, for example.
    As well my custom theme I created solely for this test worked fine, both comment_form() and comments_template().

    Not so on my old theme thou, as stated above, it just suddenly started working after all the outlined steps, but there is not a clear pattern on what the real source issue is.
    (At least, I do not see it yet)

    Happy to help if you can show me what them you use, who knows maybe there is some customization in there that stops the new updates (for example customised comments template…)

    • This reply was modified 1 year, 10 months ago by Beda.

    I am seeing the same issue. I should note that I did not activate the check box when it was offered, and now cannot find the setting anywhere.

    I am seeing the same issue, regardless of theme.

    Sam

    (@forbiddenchunk)

    I’ve got the same issue in custom themes, is it a bug in WordPress or do we need to add some code to our custom themes?

    I’ve got the same issue in Avada and Infographer (qode agency). No comment consent. Everything is upgraded, wp, plugins, themes.

    • This reply was modified 1 year, 10 months ago by claudiocuce.

    I’ve found out what the problem was on my end; the Jetpack option “Let readers use WordPress.com, Twitter, Facebook, or Google+ accounts to comment”. When I disabled that, the option shows up.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘no Comment Form Cookie Consent on wp 4.9.6’ is closed to new replies.