Support » Fixing WordPress » no comment entry ability?

Viewing 11 replies - 1 through 11 (of 11 total)
  • well, the form isn’t in the html. do you have comments off or something? hmm

    I’m having this same problem. I detailed my issue in another thread, but I haven’t gotten any responses yet. 🙁
    And, I do have comments turned on under Options.

    I double-checked–I do have comments enabled.
    I see that the code for leaving a comment appears to be pointing to the pop-up comments, even though I don’t have them enabled. How should I edit this code, then? Thanks!
    <div class="feedback">
    <?php wp_link_pages(); ?>
    <?php comments_popup_link(__('leave a comment/tb'), __('Comments (1)'), __('Comments (%)')); ?>
    <?php trackback_rdf(); ?>
    <?php include(ABSPATH . 'wp-comments.php'); ?>

    I just reverted to the default index template (pulled from the zip file) and inline comments still don’t work. I uncommented the code in the header and the pop-up comments worked fine, displaying comments and the submit box, but I don’t want pop-up comments. I want inline comments.

    I think we’re just talking to each other, Carla.

    I think I might have figured it out. I was having the same problem. I added /index.php/ to the front of my permalink line, saved the permalinks, copied the text that appears at the bottom of the permalink page into my .htaccess file, refreshed everything and it worked.
    So for instance, instead of :
    I am now using :

    Indigohat, thanks for the suggestion. I messed around with the permalink settings and .htaccess file and discovered the problem.
    My .htaccess file was just in the wrong directory. I have WordPress installed to /wp but my blog index appears in the root. I copied .htaccess to / and left my archive format as /archives/%year%/%monthnum%/%day%/%post_id% and now the comments and submit form work properly.
    I had been unsure of which directory .htaccess needed to be in, but I thought it was /wp since it needed to be there for the template editor in the control panel to access it. It just didn’t occur to me that after changes, I needed to copy it to root just as I did with index.php. To save me a little trouble, my husband set up some symlinks for me, so I can skip copying those files from /wp to / .
    In summary, your .htaccess file needs to be in the same directory that you list for your blog homepage.

    I made certain that my .htaccess information was correct, and it’s in the same folder as my index.php (and my index.php is in my permalinks). Still the same result. 🙁

    I have just the same problem as you carla. I think I’ve done everything to try to find the problem but it’s still there. I don’t know what to do.

    1. I checked and there is comment form on your single post view. So what is the “same problem”?
    2. This thread was started 1 (one) year ago – since then several new versions of WP were released, so it’s not a healthy thing to continue the discussion here, because a lot of things have been changed since.

    I’m really sorry but that’s another news posting system – Fusion.
    My WordPress is here:

    Sorry for posting here. I made another post on the forum. Thanks for the help.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘no comment entry ability?’ is closed to new replies.