Support » Plugin: WP Hide & Security Enhancer » No checkboxes are sticking

  • Resolved JJNW

    (@jjnw)


    Hi. Great GREAT plugin. But when given options, YES / NO, and I select one, these the option I select disappears, that is to say, the circle checkbox isn’t selected, they are just white. This is for all YES / NO options, though the plugin says saved (with no errors). Any suggestions? Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Also note, this is for all tabs.

    • This reply was modified 2 years, 2 months ago by  JJNW.
    Plugin Author tdgu

    (@tdgu)

    Hi,
    The issue must be caused by another plugin code or possible theme. Can you try to de-activate and see if make a fix?

    Thanks

    Okay, work with a vanilla install. Still trying to figure out what is happening. One of the tricks I used was to activate plugin while in vanilla theme, and it works just fine, but once I activate my custom theme, it gets nutty. Hopefully I will find a resolution 😉 Thanks for a great plugin nonetheless 🙂

    Plugin Author nsp-code

    (@nsp-code)

    Thanks. Let me know if you need more help.

    Please don’t forget to Rate at https://wordpress.org/support/plugin/wp-hide-security-enhancer/reviews/ , unfortunate recently many users preferred to leave bad reviews instead ask for help.. this really affect our commitment for making further development for the plugin code.

    Okay, after running a series of “WHAT THE F” – I found out my code in functions.php was messing up your plugin.

    So, for future knowledge, I should not use this code, else find alternative way for writing it (if possible) without conflicting with your awesome plugin.

    /* START keep all short words of 3 characters or less from showing in URL */
    add_filter('sanitize_title', 'remove_short_words');
    function remove_short_words($slug) {
        if (!is_admin()) return $slug;
        $slug = explode('-', $slug);
        foreach ($slug as $k => $word) {
            if (strlen($word) < 4) {
                unset($slug[$k]);
            }
        }
        return implode('-', $slug);
    }

    Removing this code from my themes functions.php allows your amazing, free, awesome support plugin to work 🙂

    Again, thank you, sincerely and I hope your days are well.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No checkboxes are sticking’ is closed to new replies.