WordPress.org

Support

Support » Plugins and Hacks » [Resolved] No bar graphs in stats

[Resolved] No bar graphs in stats

  • It’s been a couple of months now and I still don’t have any bar graphs in the site stats. I have the latest WordPress version, Windows XP, and I use Chrome as my browser.

    I can see the bar graphs in Chrome on my Windows 7 machine, and they’ve viewable on my XP machine in both Firefox and IE.

    Did Chrome and Jetpack exchange unpleasantries at some point? Why can’t they get along?

    http://wordpress.org/extend/plugins/jetpack/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Miraculously, the bar graphs in SiteStats reappeared a couple of days ago. Just as remarkably they have now disappeared again.

    Does any actually monitor this forum or am I just wasting my time?

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    Could you try to check your Stats on WordPress.com home page, and see if you experience a similar issue?
    http://wordpress.com/#!/my-stats/

    If the problem only happens in your dashboard, could you try to deactivate all your other plugins one by one, in order to check if one of them conflicts with the Site Stats.

    You might also want to clear your browser cache, since you mentioned that the problem did not appear in all your browsers.

    I hope this helps.

    The bar graphs are missing in both the Dashboard and on the WordPress Stats site. Here’s a screenshot from the WordPress Stats page:
    http://cambridgecivic.com/WPStatsScreenshot.gif

    I suppose this means that this is a problem with how Chrome operates in a Windows XP environment because I can see the stats in Windows 7 and in other browsers. I have encountered no other problems with Chrome – just this.

    I should also mention that I can see the text of some of the statistical information on mouseover. It’s just the graphics that are missing.

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    Thanks for the additional details!

    Upon some more investigation, we think the issue may be related to a recent release of Chrome.

    Our stat charts use “canvas” for rendering the histogram, and every Chrome after version 22 treats the canvas element in a new way.

    In order to verify whether or not this change is in fact the cause of missing stats, we ask that one of you who has this issue try the following:

    1. Visit the page chrome://flags/ in your Chrome browser
    2. Click “Enable” next to the two items shown in this screenshot: http://cl.ly/image/150b1m3k0L0r
    3. Restart the browser and see whether the bars have returned

    Thank you!

    You can find more information about this bug here:
    http://code.google.com/p/chromium/issues/detail?id=122145#c11

    Thanks, Jeremy. This appears to have fixed things.

    Well done!

    Marc
    Member

    @jmaimarc

    OMG JEREMY YOU ARE MY HERO!!

    I had given up on ever seeing those damned stats bars ever again.

    Take a bow, dude. And tell your boss you need a raise.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] No bar graphs in stats’ is closed to new replies.