Support » Plugin: WordPress Backup and Migrate Plugin - BackupGuard » No backups since update!

  • Hi!

    Since the update to 2.31 no more backups are created.
    Inside the randomized backup folder there are several .log files, one for each backup attempt. Yet, none of them contains anything except for a header.
    The backup folder belongs to my user and has permissions set to 757, all the log files are 644 and belong to www-data.
    There are no relevant error messages in my logs.

    What can I do to narrow down the problem?

Viewing 15 replies - 1 through 15 (of 20 total)
  • … it should of course say v2.1.3 instead of v2.31.


    You should change the owner of the backup folder to www-data.
    The php error log should contain info about why backups aren’t getting created.

    You were right, of course, there is a PHP error in the log that had slipped my attention.

    PHP was complaining about a missing function called “curl_version()”, even though I had curl disabled in the “Enabled transports” settings.

    Installing the curl extension fixed the problem. But you might want to make the call to “curl_version()” dependent on the state of the curl checkebox.

    Thanks for your assistance!

    But you might want to make the call to “curl_version()” dependent on the state of the curl checkebox.

    You are right, I will fix that.


    The big question…

    I have a multisite installation. Will your tool allow me to back up the entire site in a single backup or will I need to backup each site separately?


    I did not test the plugin against a multisite setup, but I think it should work.

    You should try it and then tell us your results.


    I hate to keep bothering you, but I’m not quite there yet. Backups are created sucessfully on my server now, but the upload to Google Drive fails.
    I’m getting a

    Received response code ‘400 Bad Request’ while trying to upload a file chunk.

    This consistenly happens when the very last chunk is being uploaded (according to the progress bar). I’ve played around with the chunk size settings and timeouts, and I’ve revoked/re-authenticated towards Google several times. None of that has resolved the problem.
    I also tried all the transport options one by one. That has had no effect either, except that upload speed is extremely slow without curl enabled.

    Any suggestions?

    If it’s any help, I got plenty of these in the debug.log:

    PHP Notice: Undefined index: status in /crypt/srv/www/htdocs/xxxx/wp-content/plugins/backup/backup.php on line 1410

    … and a couple of those:

    PHP Notice: Undefined variable: text_domain in /crypt/srv/www/htdocs/xxxx/wp-content/plugins/backup/backup.php on line 1221

    No clue?

    i want to install pagination in below my home page how would i do?

    ^^ wut i think you are lost sir

    [Please stop posting in uppercase. It’s the electronic equivalent of shouting and is considered quite rude. Post de-capped.[/em>


    PHP Notice:

    Those aren’t really effors, the varibles just are not declared. It’s very common and doesn’t impact performance or functionality. In other words, it’s nothing to be worried about.

    Received response code ‘400 Bad Request’ while trying to upload a file chunk.

    95% of the time this is because of a problem on with your connection being too slow and timing out. Use small chunks, and if you are on shared hosting, there’s prolly nothing you can do about it. It’s just too slow to send the chunk before the script times out.

    Try .5 MB chunk with a 60 second timeout.

    Backup is working here on my online development server (shared hosting), using the latest v2.1.3

    However, I have noticed another reason why scheduled backups don’t work.
    I often install Backup in an early stage of development in order to have automatic backups during development.

    When I work on a new website for a client I often protect the access by setting a http password protection in .htaccess and an accompanying .htpasswd.
    I have found this prevents Backup from performing scheduled backups.

    Would be nice if this could this be solved.



    You can set up a cron job and use something like this for the URL.

    ^^ Good answer!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘No backups since update!’ is closed to new replies.